Canon Community Canon Community
 


Reply
New Contributor
Posts: 3
Registered: ‎02-02-2017

650D self-timer's gone crazy!

Hi, I've had this problem for some time now. When I want to use a 10-second self-timer, the camera shoots photos by itself like crazy. It just started doing this out of nowhere. It doesn't even count 10 seconds, but takes photos one after another continuously until I somehow manage to set a different mode. I've had this camera 4 years and everything was OK until now. It hasn't fallen down or anything. I've already tried firmware update and it seemed to work for a while. However, after using it for a couple of minutes, the same thing happened. Replacing batteries doesn't work, neither does changing lenses. 2-second self timer works, as well as everything else.

I'll probably need to get it serviced, but just wondering if anyone has or had the same problem, or maybe knows how to fix it without sending it to service place.

Moderator
Posts: 1,436
Registered: ‎10-25-2012

Re: 650D self-timer's gone crazy!

Hi ephemericbeauty!

 

Thank you for reaching out to Canon USA, we're happy to help!

 

Here in the US, the 650D is called the EOS Rebel T4i.

 

We think you might have the custom-timer set. If you want just the 10-second timer, you want to make sure the icon with the clock next to the remote control is selected, not the one with the clock, "C" and numbers - that's a 10-second timer followed by continuous shooting. To disable the timer, follow the instructions HERE.

 

If that doesn't resolve the problem, you'll want to do a full reset on your camera. This includes clearing your custom functions. To do this, change your top dial to "P" and follow the instructions HERE.

 

If you need further assistance, we'd recommend reaching out to technical support in your country or region. You can find contact information for them by clicking HERE.

 

We hope this helps!

New Contributor
Posts: 3
Registered: ‎02-02-2017

Re: 650D self-timer's gone crazy!

The thing is I don't use the custom timer set option (the one with a "C"), only the 10 second mode which allows me to use a remote. Whenever I choose this option it starts continuous shooting and it can't be stopped until I try to change the settings into a single shot or any other option, but it usually takes a while to do that because the camera just takes photos one after another. I already did the full reset and the firmware was updated to the latest version. I tried googling the problem but haven't found anything. I use my camera everyday for work so getting it serviced is the last resort.

Super Contributor
Posts: 145
Registered: ‎12-03-2016

Re: 650D self-timer's gone crazy!

Just a guess, but could this be an issue with the remote plug on the camera?  It sounds like the camera thinks there's a remote connected and being held on continuous shooting.

Highlighted
New Contributor
Posts: 3
Registered: ‎02-02-2017

Re: 650D self-timer's gone crazy!

I use wireless remote Rc-6 so I don'y think it's about that.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement