cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

canon 5D mark II, I have to press the shooter 2 times when I use in P, TV, AV, M and B How to fix?

magicwind
Apprentice

Hi, I have a Canon 5D mark II.   yesterday when I was shooting in a studio I swich from automatic to M the shoter doesn't make click, I have to press again for the camera make the click, this happen only when I select,  P, TV, AV, M and B, when I select, Automatic CA, C1, C2, C3 it works perfect,   why is happening this if some one can help to solve this problem, I will appreciate 

Thanks 

6 REPLIES 6

jrhoffman75
Legend
Legend

Sounds like you might be in Live View or mirror lock. 

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic

Hi jrhoffman75

If this happens when you are loking through viefinder, not the LCD on rear of camera, then Live View is not the cause of your problem.

 

Follow these two steps:

 

Capture.JPG

 

Capture2.JPG

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic

Sounds like it's in mirror lock up.

"A skill is developed through constant practice with a passion to improve, not bought."

Thanks Jhon and cicopo was awesome your help I did it now all good I was worrie thinking that could be something worst

Ipreciate your fast and great help

Victor

Glad we could be of help. 

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic
Avatar
click here to view the gallery
Announcements