Showing results for 
Search instead for 
Did you mean: 

T7 works great on battery, won't power up using AC adapter


Hello. I have a T7 which I've owned for about 18 months. I have 3 batteries, 1 Canon, 2 after market, and the camera works perfectly fine with all 3. I use the camera mostly in a small astrophotography rig but I cannot run all night on a single battery so I purchased a Canon AC adapter/USB cable kit. The adapter is a CA-PS700 and the DC coupler is a DR-E10. It fits the camera fine, latches in just like a regular battery. The cable goes through the little opening on the side and the battery cover closes correctly. The camera sadly does not power up. I stuck a volt meter on the DC coupler and it reads 7.6V DC so it appears to be producing power. However when the camera is on the screen is off and I cannot take pictures so it does appear that the camera isn't working. 

Does anyone know why this wouldn't work? Is there something in the settings area that I would need to adjust (which I can do using a battery) to enable this feature?

I tried an after market AC power adapter and get the same results.

Thanks in advance for any suggestions on how to get this going.



Have you used the viewfinder in place of the screen? Does anything show up there? Not able to help with the original question as it has me puzzled, too.


I can see through the view finder but it won't focus a lens and I don't even get any of the focus dots.

Over USB with a battery plugged in I can control the camera from my Raspberry Pi controller including remote focusing and viewing live video coming from the T7 in the house on a PC.

With the AC adapter plugged in there's nothing. The Raspberry Pi doesn't see the camera and nothing works at all.

While I don't have an accurate way to measure I have a suspicion that the gold DC Coupler contacts are slightly more recessed inside the plastic than the gold contacts on the batteries. If that's what's happening then possibly the camera just doesn't actually get power at all. I'm doing this by feel with my fingertip and finger nail so it's a highly suspicious measurement.

Not only that but the DC Coupler also has an extra piece of plastic sticking that might serve to stop the coupler from going into the battery compartment as far as a battery. If I suddenly became brave I might consider filing that off but I didn't want to start there.

Thanks for at least conversing on the subject. Much appreciated.


SOLVED --- I took the camera into Tucson Camera Repair this morning to have them look at it. It seems that one of the electrical pins down in the battery compartment was pushed down and sticking so she popped it loose and now both the battery and AC power adapter appear to be working fine. I now know what to look at and if it becomes a reoccurring problem I'll look into having it serviced.


08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/28/2022: New firmware version 1.2.1 is available for EOS-R3
07/21/2022: New firmware version 1.6.0 is available for EOS-R5
07/21/2022: New firmware version 1.6.0 is available for EOS-R6
07/21/2022: New firmware version 1.1.0 is available for EOS-R7
07/21/2022: New firmware version 1.1.0 is available for EOS-R10
07/14/2022: New firmware version 1.0.1 is available for CR-X300
07/01/2022: New firmware version 1.3.0 is available for PowerShot PICK
06/30/2022: Service Notice: EOS 70D: Error 70 or Error 80
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version is available for EOS-C500 Mark II
05/26/2022: New firmware version is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version is available for EOS R5 C
03/23/2022: New firmware version is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x