Showing results for 
Show  only  | Search instead for 
Did you mean: 

Smartphone can no longer connect to Canon 6D after upgrading to Android Lolillipop


I upgraded my One Plus One phone to Android 5.0 also known as "Android Lolillipop". Since that upgrade I can no longer connect my smartphone to my Canon 6D using Camera Access Point Mode. The camera's WiFi SSID is visible, and the phone attempts to connect but gives up (going from 'connecting...' to 'saved'). I've tried to disable Internet access (by setting to airplane mode) as someone suggested in the forums, but without success. I am having this problem for a couple of weeks now, and tried at different locations, so I don't think it's interference. I have no clue what to try now.. 


Since the cell phone OS is what you changed, that's most likely where the problem is. A modern smartphone using wi-fi can usually function as either an access point or a client. Since you've configured the camera to be an access point, the cell phone should be configured as a client. Probably the upgrade wiped out some or all of your previous settings. So make sure that the phone is configured as a wi-fi client and that it has any security keys necessary to connect with the camera.


BTW, I'm not certain of this, but it seems to me that turning off Internet access on the phone is exactly the wrong thing to do. Since the phone is a wi-fi client, it presumably sees the camera as the Internet. Turning off Internet access may disable its ability to see the camera at all.

Philadelphia, Pennsylvania USA

Agreed Robert, I think it's an OS problem, specifically an Android Lolillipop problem. I am not the only one with this issue on Lollipop. My assumption is that the Android EOS Remote app needs to be updated for Lollipop.


Did you ever resolve this problem? I'm having exactly the same problem after updating my Blu Life One X smartphone to Androif 6.0 from 5.x.

click here to view the press release