Showing results for 
Show  only  | Search instead for 
Did you mean: 

Rebel T7 busy and will not take a picture


My camera was working fine and yesterday it would not work.   When I powered it up the back display was black and none of the functions on the back would work.  When I looked through the view finder there was a busy signal.  It acted like it wanted to focus but wouldn’t and the shutter would not release. 
I changed from AF to Manual focus and still no joy.  I changed lenses and still the same issue.  Changed SD cards still no joy.  
I can’t change settings because the back display does not work nor any of the functionality buttons.  
Please advise on what to do to resolve this issue.   Thanks in Advance.   Jim R. 



Remove the lens (and re-install the protective cap in its place).  Remove the SD card.  Remove the battery, wait for a bit, then reinstall and power on.   If you're able to now get to the menus, try performing a camera reset.

If the camera though fails to work with lens and memory card, or fails after you re-attach/re-install those items, probably should call up Canon to schedule a repair.


Camera: EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L
Lighting: Profoto Lights & Modifiers

Yeah it didn’t work.  I took it back and exchanged it.  I hope I have better luck with this one. 


What is the storage capacity of your memory card?

Are you using full size memory card or a micro-SD card with an adaptor? 

Did you format the memory card in the camera prior to first use?

"The right mouse button is your friend."