Showing results for 
Show  only  | Search instead for 
Did you mean: 

R6 mark ii not communicating with Samyang EF 85mm MF lens


Hi, I have an EOS RP and have been using a Samyang XP 85mm f1.2 manual focus lens with an EF mount with no problems using an original Canon EF to RF adapter. I recently bought an R6 mark ii and when using this same adapter and lens, the place where the aperture is displayed disappears and taking a picture leads to a black screen that does not go away even when turning the camera off. If I take the lens and adapter as they are and use them on the RP, they work again. Other lenses work fine on the R6mii so I don't think the pins are damaged (plus it is brand new).

I have tried turning on the Release shutter w/o lens and turning the stabilization off with no success. 

Any help would be well received.



The lens is NOT compatible with your camera. It may have been compatible with your old camera but not your new one.


Current Gear: EOS 5D Mark IV, EF Trinity, EF 50mm F/1.8 STM, EF 85mm F/1.8 USM, 470EX-AI & 600EX II-RT

Retired Gear: EOS 40D & Sigma 17-50mm F/2.8 EX DC OS HSM


Canon just released a firmware update within the past week or so.  I normally do not recommend updating firmware to fix a malfunctioning camera.  But, your camera seems to be otherwise fully functional, except for this one special case. 

"The right mouse button is your friend."

I also tried updating the firmware of the camera to 1.1.2, it is the latest version, but it did not help


I would reach out to the third party lens manufacturer. They have their docks to upgrade the firmware when a new camera comes out.

I had a look at their website, but they only have firmware updates for their auto focus lenses, not for this one as it is manual focus only. I'll try to contact them directly and get back to you.


I have replaced my EOS R by and R6MarkII. With the Samyang AF 14mm RF the camera freezes and one must remove the battery to restart it. I upgraded the firmware from 1.0.0 to 1.1.2. The canera now does not lock up with the Samyang, but is not able to read the AF/MF switch nor the F-stop value. 

I bought the Samyang because there was no 14 mm option from Canon at the time, but this was clearly a mistake!

I strongly suggest that you start a new thread for your issue.

"The right mouse button is your friend."

I agree that the lens is different, but the problem is the same. A Samyang RF lens will not communicate with the R6 Mark II. Presumably Samyang use the same communications routines in both cases, so if they fix one they could fix the other. However, Samyang and/or Canon would need to update their firmware. It seems that in the case of the problem with Samyang and the R5 firmware1.3 release, Canon later updated the R5 firmware with a fix, so maybe this is necessary for the R6 Mark II?

Its NOT Canon's responsibility to make 3rd Party gear work with their cameras. So you'll need to contact Samyang for a firmware update to the lens.


Current Gear: EOS 5D Mark IV, EF Trinity, EF 50mm F/1.8 STM, EF 85mm F/1.8 USM, 470EX-AI & 600EX II-RT

Retired Gear: EOS 40D & Sigma 17-50mm F/2.8 EX DC OS HSM