cancel
Showing results for 
Search instead for 
Did you mean: 

Having trouble connecting Canon 50 to live stream

jordancamera88
Contributor

Hi there. I am looking to connect my Canon m50 camera to my computer so I can live stream on Streamyard and/or Zoom. 

For some reason my MacBook Pro computer won't connect to the camera. I see the screen below.

I have installed the Canon Web Utility Drive from the company's website. I also have restarted my computer. 

Things I have tried:

  • Connected the camera to my computer by connecting one end of an HDMI cord plugged to the camera, the other end into a -> HD Capture Card into -> USB converter > to my MacBook Pro (Monterey) 

  • Connected the camera to my computer with a standard USBC cord.

None of these methods seemed to work.

Any help would be greatly appreciated! I can't figure out what to do. 

This is the error I see:

Screen Shot 2021-12-20 at 9.20.25 PM.png

17 REPLIES 17

Waddizzle
Legend

You most definitely want to use a USB cable with the EOS Webcam Utility, not an HDMI.  If you use an HDMI cable and a capture device, then any issues are most likely the fault of the capture device.  Also, you do not want to connect both an HDMI and a USB cable at the same time.

https://www.usa.canon.com/internet/portal/us/home/support/self-help-center/eos-webcam-utility/ 

If you are getting that display, then the EOS Webcam Utility is not seeing your camera.  You should also make sure that the app you are trying to use with the Webcam Utility is actually compatible with it.  Canon has tested a number of apps, but they cannot test every app out there.  Even then, there is no guarantee that a given app should or must work with the Webcam Utility.

Check your USB cable.  Make sure that you are using a USB data cable, not a USB power/charging cable.  One way to check is to see if your camera connects to the computer using the conventional EOS Utility app for downloading images from the camera.

You also need to make sure that no other app is trying to connect to the camera when you use the Webcam Utility, including the Canon EOS Utility for downloading images from the cameras.  The camera can talk to only one app at a time, and it will not automatically switch on its own.

--------------------------------------------------------
"The right mouse button is your friend."

On the Mac, that includes Image Capture.

Hey, not quite sure what you mean. Make sure Image Capture is not active? 

Yes, run image capture with the M50 attached with USB and set it to not do anything when it is plugged in.

This is what I see. I'm wondering if it's the cable that's not right. 

Screen Shot 2021-12-21 at 9.56.32 AM.png


@Waddizzle wrote:

Make sure that you are using a USB data cable, not a USB power/charging cable.


Thanks so much for your reply. Wondering if this might be the main issue? The cable I was using might not be the right thing. Does this look sufficient? 😅 

https://www.amazon.com/dp/B071S5NTDR/ref=as_li_ss_tl?tag=httpthinktv-20&_encoding=UTF8&linkId=445ed5...

I am confused. Above you said it was a "standard USB-C" cord, but the cable you linked to is USB-A.

I'm confused too 😂 

I'm not sure if the cord(s) I am using are sufficient. The Amazon link I posted earlier is what I was looking into getting based off some YouTube videos that talk about live streaming. 

Anyone know what cord I for sure need to use? 

What ports do you have on your MBP?

Announcements