Showing results for 
Show  only  | Search instead for 
Did you mean: 

Eos Rebel T6i not getting recognized by Windows 10 and Eos Utility 3


Hello, everybody!


I'm new here, so please, if I'm posting in the wrong place, let me know.


I have a T6i for almost 2 years and it's a recurring problem, sometimes I solve it by just simply downloading the EOS software and reinstalling the dirvers, but this time, it's different.


I try to connect my camera to my notebook, but it's not getting recognized by Windows.


I have already turned Wi-Fi/NFC off, and I've already updated the camera drivers, still nothing. Before updating them, my computer wouldn't even make that "Device connected" sound. Now it makes the sound, but the camera doesn't get recognized, neither listed in the devices list, nor that little PC icon show up in the camera visor. The cable is original.


I don't know what else should I do. Both computer and camera work completely fine. I have already used my camera on my computer this year, the same problem happened, but I updated the drivers and everything worked fine. I just want to install some picture styles on it, if you have any alternative it would be very welcome.


I suspect it has something to do with the last Windows 10 update, but it's just a guess.


Any thoughts?


Thanks in advance 🙂


Without any Canon software does WIndows 10 see the camera?  It should show in Explorer.

EOS 1DX and 1D Mk IV and several lenses!

No, It shows that there's a driver error, and an unknown device is connected. I know it's the camera because when I disconnect the cable, the Unknown Device disappears.
It's taking a while to restore, I'm using my phone here. Later I'll see what it results and tell you

There are no drivers needed for WIndows 10 and Canon cameras.  This may help where you need to look for the problem.

EOS 1DX and 1D Mk IV and several lenses!

Bad news, nothing happened 😕

I tried to restore Windows, reinstall the drivers, but no luck 😞

You need to call or email Microsoft.  I doubt this is a Canon issue.  It works as I do it every day.

EOS 1DX and 1D Mk IV and several lenses!

I found the solution (You might think I am dumb after this lol)


So, I was convicted that the USB cable I was using was the original. I was wrong. The original was in another case, I was using an old cable from an old camera that I have here. So yeah, changing the cable worked.


I'll tag the cable to make sure this annoying problem doesn't happen anymore.



Thanks you all for the help! You can close the topic. 😄

Glad you found the solution. I was pretty convinced it was not a Canon issue.

EOS 1DX and 1D Mk IV and several lenses!

I used to think that a USB cable was a USB cable was a USB cable. But some members here and on other sites have pretty much convinced me that some are designed primarily as USB charging cables, some work better as data transfer cables and others may be suitable to do both jobs. I guess this explains why two similar looking cables can vary wildly in pricing and performance.