cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Rebel T7 won't show in OBS if turned on before opening OBS

ramoses
Contributor

I'm contacting the forum to report this bug that my EOS Rebel T7 won't show up in OBS with EOS Webcam Utility if the camera is turned on before opening OBS. I can only fix it after turning it off and on again if OBS is already running, it can confuse the user since this is not the best behavior of the tool.

2 REPLIES 2

Nick2020
Product Expert
Product Expert

Hi ramoses,

Thanks for sharing your experiences with EOS Webcam Utility.

It is possible that is a quirk, but let's check a few things first.

We have two programs with similar names. EOS Webcam Utility is for livestreaming, but it won't work if EOS Utility is running, even if it is running in the background in the system tray. Check the icons on the bottom right of your screen and right click on any EOS Utility icons and close them.

After doing that, check the Wi-Fi setting in the camera's menu and make sure it is turned off. Otherwise the camera's USB port won't be active, and EOS Webcam Utility needs a USB connection.

Then make sure that the camera is set to shoot movies, not photos.

It might also help to try disconnecting other accessories from the computer and to try different USB ports, since some USB ports can be stronger than others.

Beyond that, it might help if you download the latest version of the software:

https://www.usa.canon.com/support/eoswebcamutility

Sorry for the late reply, here are the things I noticed:
- I double-checked if EOS Utility (not EOS Webcam Utility) was unable, system tray and Task Manager; 
- Wi-fi wasn't enabled as well;
- USB was ok (Windows was recognizing the Camera);
- Changed the preset from "Manual" to "Camera Shoot;

Now for some reason, the bug is not happening again. It would change the Camera Canva (black bars around the image would appear and I would have to resize the source and even not show at all the Camera if it was turned on when OBS was already running (had to close OBS, turn on and off the camera).
The only thing I did differently from last time was choosing the Shoot movies instead of Manual (not sure if this was actually what made it work).

Avatar
click here to view the press release
Announcements