Showing results for 
Show  only  | Search instead for 
Did you mean: 




  I have this camera for more than 1 year. Since it has no wifi function, in order to connect the camera with my iphone, I bought an wifi adapter from Amazon. Maybe the Canon Wireless File Transmitter WFT-E8A will work but its too expensive.

  This cheaper wifi adapter was working well, but it doesn't work now. I am sure that i am doing the same steps as before. But at the last step, i open the app Camera Connect, nothing shows on my iphone, its not pairing.

   I dont know what's the reason of this , maybe I touched some settings? I tried Clear all camer settings but it still  didn't work. I assume this is not a hardware issue, hopefully its only a setting issue. Because of this, i dont want to mail it to the service center.

  Someone please help me, any answers will be appreciated!

  Thanks a lot!





I connect my 1DX Mark II to my PC via ethernet and a Windows 10 update 2 weeks ago screwed up the network settings for the ethernet port on my PC and reset the firewall permissions.  To get everything working properly I had to go back into the network settings in the camera and also set things up on the PC.  There have been a couple of IOS updates lately so perhaps one of those is creating an issue with the connect app on your iPhone.  


Also try using your wifi adapter with some other device because it may have died.  Some of the miniature WiFi devices that are about the size of a SD card are notorious for dying from heat after a fairly short life.  Check the review section of Amazon for the device you chose to see if that is a reported issue.


And yes, after many years of using PC DOS and then Windows I absolutely despise Win 10-mostly the goofballs at MS who cannot understand that customers do NOT want software to screw with their system settings every time there is an update.  If Canon would port DPP over to Linux it would be the best Christmas present ever.



EOS 1DX M3, 1DX M2, 1DX, 5DS R, M6 Mark II, 1D M2, EOS 650 (film), many lenses, XF400 video

Hi Rodger,

  Thank you so much for your very kind answer!

  I bought a new travel adapter from amazon, but the issue still happens.So I think that the setting issue instead of the adapter.

  I tried to restart the network setting from the camera side, and there was a new issue so I still can't make the connection. It is pretty sad.

  Probably as you said, when I connect the camara with the pc (ios system), it automatically modifies my camera setting for some reason. That is totally unreasonable and now i'm trying to contact the customer service, if there were any helpful answers I will let you know.

  Hopfully they don't let me buy the official wifi adapter.

  Thank you Rodger and have a nice day!



click here to view the gallery