Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon EOS R3 Freeze-up Issue - The likely cause!


My friends,

I believe I found the issue causing freeze-ups in the Canon R3!!!

Recall the following:

1) I experienced freeze-ups with my Canon R3 the first week I received it.

2) Canon CPS took the camera in for repair, replicated the issue, reinstalled the firmware, reset it to factory settings, tested it, found no more freeze-ups, declared it fixed and returned it to me.

3) I restored my settings manually and the freeze-ups still occurred.

4) Canon replaced my original R3 with a brand new R3

5) I updated my firmware to V1.1.1 and restored my settings from a CSD file this time, and the freeze-ups still occurred.

6) In all cases my freeze-ups were such that the buttons and dials would not respond (including power switch), yet touch functions still functioned including the smart controller. It would also freeze-up, at times, while asleep and could not be awakened. Of course, since the screen was black (asleep), no touch function could work. The only way to restore the camera was to pull the battery and then reboot the camera.

I have since, of course, contacted Canon and am awaiting a response, as Canon's engineering department seems to be in a denial mode, despite a Canon repair technician in Virginia having replicated the freeze-up issue when it first went in for repair.

I advised Canon that while I await their response, I was going to, one by one, change my settings to default and see if any particular setting eliminated the freeze-ups.

My first setting change was to restore the aperture and speed change dial settings to default, as I had them reversed. No change. I still had freeze-ups, so I restored my setting.

Next, I reasoned that, since the freeze-up even occurred while the camera was asleep, the only function I had changed that would involve activity during the sleep mode would be the GPS setting, which I had set to Mode 2. I disabled the GPS altogether. Since I have done so, I have left the camera on 24x7. Not once has it failed to awaken from sleep mode nor has it frozen at all while awake and being used. I have been testing for a solid week now (on 24x7) and I'm optimistic that this is the cause of the freeze-ups, as before I could rarely go a day without a freeze-up.  

I'm asking that some of you who are experiencing freeze-ups with the R3 such as I have been experiencing to check this setting and 1) verify it is enabled on your camera and 2) verify that by disabling it that the freeze-ups no longer occur.

Similarly, those of you who have an R3 and have experienced no freeze-ups, can you verify that your GPS is disabled.

Again, I'm optimistic that this is the issue, but I'd like to get feedback from others to verify what I'm experiencing before I approach Canon.


Canon EOS R3, Canon EOS R5, Canon 5D Mark IV, Canon 7D, Canon EF 14mm f2.8L USM, Canon EF 17-40mm f/4L USM, Canon TS-E 24mm f/3.5L, Canon EF 24-105mm f/4L IS II USM, Canon EF 135mm f/2L USM, Canon EF 180mm f/3.5L Macro USM, Canon EF 100-400mm f/4.5-5.6L IS USM, Canon EF 600mm f/4L IS USM, Canon EF 50mm f/1.4 USM, Canon EF 100mm f/2.8 USM Macro Lens, Canon RF100-500mm F4.5-7.1 L IS USM, Canon RF800mm F11 IS STM

Lenses were with another post, but here goes.  All Canon L glass.  RF100-500, EF135, & EF17-35, the latter two with Canon adapters.  Complete Canon all the way.  CF card not an issue as it has occurred with the CF card removed.  Two different SD cards, both high end and so I think you can rule out SD cards.  The only thing I’ve done is disable GPS mode 2.  Boom, no more freeze up for two weeks running.

Canon EOS R3, Canon EOS R5, Canon 5D Mark IV, Canon 7D, Canon EF 14mm f2.8L USM, Canon EF 17-40mm f/4L USM, Canon TS-E 24mm f/3.5L, Canon EF 24-105mm f/4L IS II USM, Canon EF 135mm f/2L USM, Canon EF 180mm f/3.5L Macro USM, Canon EF 100-400mm f/4.5-5.6L IS USM, Canon EF 600mm f/4L IS USM, Canon EF 50mm f/1.4 USM, Canon EF 100mm f/2.8 USM Macro Lens, Canon RF100-500mm F4.5-7.1 L IS USM, Canon RF800mm F11 IS STM

View solution in original post



Same issue, my camera had the white box flashing as if it were taking images.
Had to pull the battery, and GPS has been off since day one.
R3 with adapter and EF 600mm attached. 😞


Curious to see if the new R3 firmware also nips the GPS Mode 2 lockup bug. I plan on updating when I get back to my office and will turn GPS back on to see what happens. Has anyone else turned it back on with the new firmware?

Yes, put the new firmware in and still have freezing and stuttering, mine is quite regular. Have always had the GPS off.


I’m experiencing a different kind of freeze, where the shutter button still works but the auto focus will not respond. Happens with EF 70-200 2.8 and so far with just one of my three R3s. Tends to happen when camera has been sleeping and is raised from my shoulder, 99% of the time in vertical mode. I never have enabled GPS. Sent the camera and lens to Canon last week and when it was returned they said they couldn’t duplicate the problem, so it’s an intermittent and that’s a nightmare. They said they were aware of the freezing issue and were “working on a solution”, but no mention of upgrading to the firmware they just released, so I have my doubts. There are a number of different possibilities being floated on other R3 forums, with different descriptions of how it happens, so that’s discouraging. I believe they are working hard on this but patience is an expensive proposition for a working pro.


I have both the Canon R5 and more recently the Canon R3.  My Canon R3 stutters sometimes when I try to take photos and regularly freezes, and as I take animals it is far from ideal.  My GPS is always off.  Marie



Hi, I also experience same freeze-up issue with R3, GPS ON (Mode 1) update every 30 sec. + GPS logging ON. Camera Firmware 1.2.1 Using with RF 100-500. My R3 will freeze around 3 times a week, the power on/off doesn't work when it's freeze-up. Removing battery is the only way to solve the freeze-up issue.

Will try to turn off GPS and hope this will fix the freeze-up issue.



So I’ve owned the Canon R3 since December 2021, and I ‘ve used it shooting basketball, gymnastics, baseball, lacrosse all throughout the spring with no problems.
In June I was shooting a swimming meet and the camera froze.  The focus cursor (spot) went to the upper left corner of the display screen and no buttons worked on the camera.  Even the power was unresponsive.  I pulled the battery to reboot the camera and continued shooting.  It froze again with a different lens.  The next week I tried out different cards, and had the same issues.
July I sent it to CPS with no luck of them replicating the issue.
Again in August shooting a field hockey game it froze, so I sent it in again to CPS.  Again no luck
I’v tried updating the firmware, turning off Bluetooth, and the GPS has never been turned on.
It seems that after about an hour of shooting the camera starts to act up.
So September shooting a football game and a volleyball game it froze again.

I’ve attached a photo of the issue.  You can see the focus point in the top left corner of the screen and none of the buttons respond.

I am a Platinum member and I bought the CarePak on this camera when I bought it.

So far I've been very disappointed with the response and support.

when I push any buttons I get a "busy" notificationwhen I push any buttons I get a "busy" notification


Power button doesn't even workPower button doesn't even work


What is the point of being a Platinum member and purchasing CarePak?

Product Expert
Product Expert

Hi jagn4,

I'm sorry to see you're continuing to have issues with your camera after multiple repairs. The Busy message is shown while the camera is in the middle of a process it needs to finish. Once that process is completed the Busy sign would go away and the camera can be used again. While the camera is Busy it can cause buttons and dials to become unresponsive.

One thing to check with an issue like this would be to load different memory cards in the camera to see if the same thing happens. The most common reason for that message to be displayed is that the memory card is still trying to write files. If the buffer is full, or if the card is malfunctioning, it can cause that message to show. 

If the issue continues try unplugging any attached accessories to see if the same thing happens. Sometimes if accessories are malfunctioning it can cause a camera to freeze like this.

If the issue continues at that point we would recommend calling the CPS hotline to discuss repair warranty and CarePAK options.

Hi Hazel-

Thank you for taking the time to try and help me trouble shoot the issue with my R3.

I don't think this is a buffering issue.  I've used different cards with the same result having the camera's controls freeze.  The photo doesn't show the buffering light NOT being on when the camera freezes.  I have seen the camera being "busy" when I've reached the buffer limit, and the freezing is something different.

This is an example of what I've experience regardless of cards, lens or sport (indoor/outdoor)

I track an athlete and fire off a sequence of photos, maybe 3-5 shots.  Then I lower the camera as the action moves away from me.  When I raise the camera back up to my eye to take another sequence of photos the camera is frozen.  The focus cursor or focus spot is locked in the upper left corner of the display screen, and none of the buttons work.  If I push a button I get the "busy" notification blinking.  I try turning the camera off, and the power button doesn't work.  The only way to stop the camera from freezing is to pull the battery.  Once it freezes during an event, it will happen 3- 4 more times during that game.  The first time the camera freezes is about 45 min  - 1 hour into the action.  I don't know if it's an  over heating issue or something else?  Some on here have suggested turning off GPS.  I've never turned on the GPS so that workaround doesn't apply.

Again thank you for your suggestions.  I'm hopeful someone out there has had similar experiences and maybe a solution.

all the best

Product Expert
Product Expert

Hi jagn4,

Since none of the trouble shooting in my reply and the forum chain resolved the issue we would recommend calling the CPS hotline to discuss repair warranty and CarePAK service options.

Enter for a chance to win