cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon 70D rear buttons and LCD screen not working

kabbage84
Apprentice
The LCD screen not working in live camera mode. The screen will work when I set to movie mode and turn on camera otherwise it won't toggle between the two. When in Movie mode the only rear button that works is INFO. The camera does seem to take pictures although it does not let me view them. Also in movie mode thw start/stop botton does not work. Last, its not the lock button. Any ideas?
3 REPLIES 3

shadowsports
Legend
Legend

Sorry but it sounds like you've joined the 70D failed PCB / mainboard club. 

 

http://community.usa.canon.com/t5/EOS/Canon-70D-died/m-p/148015/highlight/true#M14912

 

http://community.usa.canon.com/t5/EOS/70D-froze-up-and-now-won-t-turn-on-after-removing-battery/m-p/...

 

 

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8 ~CarePaks Are Worth It

Tim
Authority

Hello kabbage84, 

 

You mention that the <INFO.> button works on your camera, what happens when you press it?  I ask because toggling that button will go through a cycle where certain information is displayed, taken away, hidden or disabled as that button gets pressed.  One of the cycles it lands on will actually turn it all the way off, so we're wondering if perhaps that happened here. 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Tee_dang
Apprentice
I tried several solutions and by playing with the several of the buttons, the solution was sooo simple. When the camera is on & and in camera mode, press the Start/Stop button to shoot using the View Finder or LCD screen.
Avatar
click here to view the press release
Announcements