cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon 5D Mark IV weird artefacts on the images

loading5
Apprentice

Hello,
recently the camera stared to act like in the images attached. It happens once at few hundreds of pictures.

Sometimes camera becomes unresponsive and can work only if restarted.
As a fact I use two types of batteries (both genuine Canon) one that came with my older Canon MKII and the one that came with the MKIV.
Anyone knows what can be the cause?
Any info will be appreciated.

Cheers,

L.

0V7A0012.jpg0V7A3888.jpg

3 REPLIES 3

deebatman316
Elite
Elite

Does this problem also happen in live view mode. What kind of memory cards are you using. The 5D Mark IV takes both CF and SD Cards. Are you using a Micro SD Card in an adapter. If so use Full Size SD cards only. No adapters.


-Demetrius

Current Gear: EOS 5D Mark IV, EF F/2.8 Trinity, EF 50mm F/1.8 STM, EF 85mm F/1.8 USM, 470EX-AI & 600EX II-RT

Retired Gear: EOS 40D

Hello,

It never happened in live mode. The memory card is a Samsung Micro SD in an adapter. I'll switch to a CF now and watch the camera's behavior.
I really hope that it's not a sensor related problem.

Your problem is more than likely the Micro SD Card in an adapter. ONLY use Full Sized SD Cards in your camera. Your camera wasn't designed for them if it was it would take them directly without an adapter.


-Demetrius

Current Gear: EOS 5D Mark IV, EF F/2.8 Trinity, EF 50mm F/1.8 STM, EF 85mm F/1.8 USM, 470EX-AI & 600EX II-RT

Retired Gear: EOS 40D
Avatar
click here to view the gallery
Announcements