cancel
Showing results for 
Search instead for 
Did you mean: 

Camera saying busy and won't take pictures

mliz2486
Contributor

My camera worked fine the other day.  Now, it won't take pictures at all.  When I go to take a picture, it will act like it is focusing by flashing and such but it will never go through.  It always says busy.  I have tried all modes, and none will work not even without flash. 

 

I have also taken the battery out, taken the card out and reformatted it, and cleared all camera settings.  Can anyone help?  I have a newborn that I would really like to be able to capture. 🙂

 

Thank you ahead of time!

155 REPLIES 155

laurac
Contributor

Hi Elizabeth

I was following your question because I'm having the exact same issue.  I am a mother of 2 little boys and have a Canon Rebel T1 EOS that  i've been using for about 3 years to capture my boys.  I always use automatic mode and have loved this camera for it's quality photos, but suddenly the other day it did the same thing yours did....just stopped shooting. says busy...sounds like it's trying to focus but won't shoot.  and will shoot inMF mode.  I didn't drop it or damage it in any way and of course am now out of warranty. I know if I take in for service it will likely be $100s and I"m wondering if I may be better off buying a new bundle.  i think it's rediculousto have to consider that after only 3 years but i suspect these just aren't built to last anymore and my money may be better spent on new stuff. Have you taken yours in yet?  if so what did they say?

I'm also in limbo like you and missing moments without my good camera around.

Thanks for your input.
Laura

laurac, if your camera _will_ take a photo in MF mode but will not in AF mode then it usually means the camera is not able to lock focus. 

 

There can be a few reasons:

 

1)  Not enough light -- test your camera in an exceptionally well lit shooting circumstance and see if the issue goes away.  E.g. shooting outdoors during the daytime, etc. would certainly be enough light to focus.  A camera will typically struggle to focus in dim/dark settings.  The choice of lens can also make a difference since some lenses collect substantially more light than others.

 

2)  Low contrast target -- a camera will typically struggle to focus if the subject (specifically the points on the subject where the auto-focus points are attempting to focus) are bland.  Plain walls or plain blue sky, etc. can lack enough contrast for the focus system to work.  The phase-detect focus system on the camera is a bit like taking a photo, printing, then cutting the image into two halves... now slide one half slightly out of alignment (out of phase) with the other half.  The camera is basically comparing the pixels along the edges of the two "halves" and when the patterns match, it's focused.  That's basically the short version of how phase-detect auto-focus works... except the sensors are only looking at small areas of the scene... not the entire scene.

 

3)  Lens malfunction -- the focus motors are in the lens itself.  It's possible to have a focus problem that only occurs with one specific lens... but another lens works fine.  If you have another lens to test, I suggest swapping lenses and testing.

 

It is possible that it's the camera itself... but that's actually fairly unlikely.  The #1 reason (not enough light) is usually the culprit (this will happen to a camera in perfect working order.)

 

Incidentally your camera does actually have two separate focus systems.  If the phase-detect AF system is not working, switch to "Live View" mode on the camera and try again... that system uses "contrast detect" AF rather than "phase detect" AF.  It is a COMPLETELY different system.  e.g. if there were a problem with your phase detect sensors then it would not impact the contrast detect system (the contrast detect system is not nearly as fast and may need to "hunt" for focus... so the phase-detect system is preferred.)

Tim Campbell
5D III, 5D IV, 60Da

Hi Tim

Thank you for your reply.  I created a new post with my question to the forum since I didn't know how this worked.  I do not have an alternate lens to switch to so can't test that but have tested lighting and can manage to capture a rare shot if i set up perfect circumstances outside with a contrasted target.

I know there is some malfunction that needs repair because as i stated before I've been shooting with this camera for 3 years in all types of lighting without any difficulty.  I'm really just trying to decide if this worth paying to repair or am I better off putting my money towards a new camera bundle.  It's very disappointing to me that such an expensive camera isn't working after 3 years of gentle use, but i hate to pour more money into a problem that might persist.

thanks

laura

Same exact issue for me. I've had mine for just over one year! 

 

EOS Rebel T3

My camera no longer takes (clear) pictures in AF, using any of the basic zone modes or other modes. I've tried in good lighting. The flash flashes sporadically, it attempts to adjust (by making clicking noises), a little green circle flashes in the lower right hand corner and ultimately either a blurred picture comes out or it doesn't ever click a picture. 

 

Basically, the same exact issues as the previous two. 

 

 

Hi Andrea,

 

Whenever someone experiences this issue, I suggest performing a few tests:

 

1)  Switch the lens to the "MF" (manual focus) mode (don't use "AF") and just see if it will take a photo.  

 

2)  Switch the lens back to "AF" (auto-focus) BUT... use the "Live View" feature to take the photo (compose the shot using the LCD screen preview instead of using the viewfinder.)

 

If the camera WILL focus and take the shot in "Live View" mode, but will NOT take the shot in normal mode (using the viewfidner), then this is probably an indication of a problem in the camera body with the phase-detect focus sensors.  In this case, it's probably the camera body that needs service.  

 

If the camera will NOT focus and take the shot either while looking through the viewfinder (normally) or in "Live View" mode, but WILL take the shot if you switch the lens to "MF" then this is a likely indication that the focus is malfunctioning in the lens itself (not the camera body).  In this case the camera body is probably fine, but the lens likely needs service.

 

The camera has two independent focus systems... a "phase detect" system (using special sensors on the floor of the camera) as well as a "contrast detect" system which uses the main sensor to find focus.  If both systems fail, then it's likely that a malfunction of the lens is to blame (the focus motors are always in the lens on Canon EOS lenses).  Conversely, if either focus system can reliably work but the other failes, then it's an indicator that the lens' focus motors are probably fine, and the issue is likely isolated to a fault in the camera body -- hence the body needs service.

 

Since all the "moving parts" are in the lens and not the body... most of the time when this happens, it's the lens (this assumes there is plenty of light... if there's simply not enough light then all modes can fail but this would not be an equipment defect.)

Tim Campbell
5D III, 5D IV, 60Da

I am having the same problem.  I have 2 different lenses and same problem.   I have cleaned the contacts.   I can take a picture if the lens is set to manual focus instead of auto focus.

 

There is plenty of contrast.    The flash will automatically pop-up.

 

But no picture is taken.

 

I have used this camera for several months as I received it as Xmas present last year.  Purchased at Costco.

 

I had same problem with "sports" setting.

 

I have a EOS Rebel T6

 

Thank you.

DeannaT,

 

Make sure you have sufficient light.  The flash popping up by itself suggests that you may be shooting in low light conditions.  Also, make sure that your subject is not within the MFD, minimum focusing distance, of the lens that you're using.  If memory serves, the 18-55mm lens has an MFD of about a foot, and the 76-300mm lens has an MFD of about a yard.

The "Sport" shooting mode setting introduces some unknowns.  Try shooting in the Green [A] mode, or P mode.  Test the camera outdoors in bright sunshine,  Aim at a subject that is about 20-30 feet away, or just over one car length.  If the camera is functioning properly, then it should take a picture.

Back to the flash unit.  The camera can use the flash to provide "focus assist beams" when the you are shooting in low light conditions.  However, this strobing of the flash discharges the flash circuitry.  If the camera senses that the flash is required to take a proper exposure, then it will WAIT for the flash circuit to recharge and flash a "buSY" message, as well as cause a lightning bolt [flash] icon to appear in the viewfinder.

 

Finally, make sure that you have a well charged battery when you using the flash.  The less charge in your battery, the longer it takes the flash to recharge.  Having a fully charged battery works best.

--------------------------------------------------------
"The right mouse button is your friend."

jpgabald
Apprentice

I had this same issue.  The camera would take pictures in Manual mode but not in auto focus. My wife and I found that a spec of dust was stuck between the UV filter and the camera lens.  The camera was trying to auto focus on the spec of dust and would not take any pictures.  We cleaned the lens and the filter. The camera started taking pictures like normal in Auto. Hopeully this simple fix helps you. 

 

 

Didn't want to start a whole new post for this issue, so decided to piggyback on this one.

 

Canon Rebel xs (roughly 6 years old).

 

Problem:  Camera does not take pictures at all. 

 

Solutions I have tried:  Took lens off and cleaned inside components.  Changed lenses.  Changed memory cards.  Tried AF and MF neither one works.

 

I do see two dust specs when I look into the camera, so I'm assuming it can't get focus because of these dust particles (I see the dust with different lenses, so it's nothing with the lens).

 

Could it be something else though?  I was hoping to fix the problem myself instead of having to take it in to get fixed...

It wouldn't be the dust... the focus sensors are on the floor of the camera.  The imaging sensor only does focus for cameras using "live view" mode.

 

You can test to see if it's a focus related issue by switching the lens to manual focus (the AF/MF switch).  In "One Shot" mode the camera wont take a photo until it can lock focus at at least one focus point.  But if you switch to manual focus it'll shoot immediately (it also shoots immediately if you swtich from "one shot" to "AI Servo" mode.)

 

 

Tim Campbell
5D III, 5D IV, 60Da
Announcements
06/30/2022: Service Notice: EOS 70D: Error 70 or Error 80
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
03/22/2022: New firmware version 1.2.0 is available for PowerShot PICK
03/16/2022: New firmware version 1.5.2 is available for EOS-R5
03/16/2022: New firmware version 1.5.2 is available for EOS-R6
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.1.1 is available for EOS-R3
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x
12/7/2021: New firmware version 1.1.1 is available for CR-N 300
12/7/2021: New firmware version 1.1.1 is available for CR-N 500
12/2/2021: New firmware version 1.1.0 is available for RF 70-200 F4 L IS USM