Showing results for 
Show  only  | Search instead for 
Did you mean: 

Camera saying busy and won't take pictures


My camera worked fine the other day.  Now, it won't take pictures at all.  When I go to take a picture, it will act like it is focusing by flashing and such but it will never go through.  It always says busy.  I have tried all modes, and none will work not even without flash. 


I have also taken the battery out, taken the card out and reformatted it, and cleared all camera settings.  Can anyone help?  I have a newborn that I would really like to be able to capture. 🙂


Thank you ahead of time!

155 REPLIES 155

What card are you using in your camera? If you don't happen to have a "fast" Class 10 card, you can get this message and if you haven't formatted the card (in camera) after doing a lot of shooting, you will get this message.

Hello everyone, I bought the Canon 70D, as it's called over here in Europe, and I'm experiencing the same issues that people are reporting on the forums of this and many other websites.


It seems to me when I shoot a few images at a time then it locks up and won't write more than 3. Almost like it will buffer upto three then it will just say "busy" and not write them to the card, or take new ones.


So far I tried the following:

 • different lenses (Canon and other makes)

 • different memory cards (of differing capacities)

 • reformatted those different memory cards

 • bought new "Ultra Fast" card

 • turned the camera off fully between shots (rather than letting it "sleep")

 • altered the position in which it sits in my bag

 • different focus modes

 • used manual focus rather then auto-focus


The only thing left is to reset it in the settings menu... I just wanted to ask if anyone had any success with this or is it just something we have to live with? I have to say if it is somehting we need to deal with daily then I will be sorely disappointed as I've previously had 15 years worth of perfection from Canon DSLR Cameras.


Thanks in advance to everyone who is trying to figure this out.





I have (3) T4i's and shoot with all three almost every week.


I have had no "camera busy" etc. messages since changing to (1) Transcend Class 10 200x 32gb in one (2) PNY Pro-Elite Class 10 32GB in 2nd body (3) SanDisk Extreme Class 10 32gb in the 3rd body.


All are SD HC 1.


I do reformat the cards IN THE CAMERAS every few hundred shots and after doing videos.


I use only Canon lenses...18-135 zoom STM, 24mm STM, 60mm macro, 10-22 zoom.


I use Canon and Wasabi batteries.


One body has powergrip and others do not.


This is the second T3i that I have purchased. After nearly a year I returned the first one. It works for a while and then stops taking pictures.  On the previous T3i the service centre has said that it has something to do with the mirror.  I have tried reformatting the card. Switching to manual from auto focus. Changing lens ... The camera is not dirty I take very good care of my camera. I always make sure that it's not subjected to extreme heat or cold temperatures and if it is I let it climatize.  Can someone please tell me what other options there are.. It was working until now. And it's not on a timer.  Now it appears that I cannot access the menu either.  I've also tried pressing the button down twice to see if by some chance it changed modes on it own. Any other suggestions?  Also it's not the lighting because there is plenty of lighting. 

!. Do you have any way to reset it to factory default?

2. Check on Canon site and see if there is a firmware update...even an old one for your camera. Follow directions on Canon site to update firmware. Maybe that will reset everything.


I have a Canon Rebel T3 that is about 3 years old. It took a small fall yesterday and is now giving me problems taking pictures. This is what I've observed:


1. Can't take pictures using the "kit lens" in AF mode (flash will pop up but picture won't take)

2. Pictures will take in MF mode

3. When I switch to "live view" I can sometimes get a picture to take but not always

4. I have tried another lens and can take pictures just fine

5. No matter what lens I use the "access lamp" light continues to flash

6. I have tried using a different SD card and still get the flashing light

7. I have cleaned the lens


I'm afraid I damaged my kit lens when the camera fell and need to replace it but I'm not sure. Is there anyway to fix this? Also why would the light continue to flash no matter the lens or the sd card?

If your kit lens was the one on the camera at the time of your fall AND it is the one lens that doesn't allow your T3 to function properly then you got off lucky as that is THE cheapest lens to replace.


I would not even try to use it anymore. The estimate on taking a look at it is more expensive or at least as expensive as buying a replacement lens of the same kind.


Look at this as an opportunity to upgrade your lenses and be thankful that it was only the kit lens and not your camera body.

The light flashing is the camera accessing the card probably and that is good. Also check your battery in the camera and make certain it is fully charged.


I have re-banged lens and they start working again but I only do that as a last resort before I toss the lens or sell it on ebay clearly labeled NOT WORKING FOR PARTS ONLY!


Good luck.


NOTE: By the way, you're not alone, I fell once while shooting a wedding and was reminded of it everytime I looked at the scratches on my usually perfect equipment.

I am having the exact problem as stated above, however, I have tried multiple lenses and they all produce the same results... It tries to focus but will not shoot a photo. Please help!

Check the earlier parts of this discussion for the problem being the memory card and NOT the lenses.

Good luck!

I was almost  ready to give up on my rebel xs until I did some research online.  I went to the Canon sight and did a reinstall on the 1.0.7 firmware.  Seems to have corrected the problem!!!!!!!!!

03/14/2023: New firmware version 1.8.1 is available for EOS R6

03/02/2023: New Firmware Updates Are Available:

EOS R7 - Version 1.3.0EOS R10 - Version 1.3.0
02/24/2023: We've updated Share Your Photos

2/07/2023: New product announcements!

EOS R8 EOS R50RF-S55-210mm F5-7.1 IS STMRF24-50mm F4.5-6.3 IS STMRF15-30mm F4.5-6.3 IS STM
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version is available for EOS-C500 Mark II
05/26/2022: New firmware version is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version is available for EOS R5 C
03/23/2022: New firmware version is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.