cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Cannon 18-55mm zoom in issue

Gawa
Apprentice

I have a kit lens of 18-55mm. However, recently while zooming in the 'subject' gets blured but when I zoom out it works fine. This happens in all the mode. I tried to resent the camera to factory setting too but still the same issue. Can any one through some light please. Thanks

5 REPLIES 5

jrhoffman75
Legend
Legend

Welcome to the forum.

 

Are you half-pressing the shutter button to cause the camera to focus?

 

You may be too close to the subject. Try focusing on something far away from the camera and then zoom it. Does the same thing happen?

 

 

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic

rs-eos
Elite

Are you perhaps recording video? I'm not sure the 18-55mm kit lens would be parfocal.

--
Ricky

Camera: EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L
Lighting: Profoto Lights & Modifiers

"This happens in all the mode."

 

If it happens in "all mode(s)" I doubt it is just video. Basic question the lens is on the AF side of the AF/MF switch?

 

Best test. After you fully reset the camera and that includes all custom settings too, set it to P mode. Set ISO to 200. Select One shot, never Ai-servo, and daylight WB. Now on a nice day do an outing and take several pictures of various subjects. Make sure you have some vertical lines like trees or a fence or buildings in the random shots. Not too close to anything. If it works, it works and there is nothing wrong. If it doesn't either the lens or camera is faulty.

EB
EOS 1DX and 1D Mk IV and less lenses then before!

Waddizzle
Legend
Legend

@Gawa wrote:

I have a kit lens of 18-55mm. However, recently while zooming in the 'subject' gets blured but when I zoom out it works fine. This happens in all the mode. I tried to resent the camera to factory setting too but still the same issue. Can any one through some light please. Thanks


For a kit lens, that sounds pretty normal to me.  As you change the zoom setting, the focus should change.

 

BTW, what camera are you using?  

--------------------------------------------------------
"The right mouse button is your friend."

"... sounds pretty normal to me"

 

It does to me too but do the test to make sure. If it works OK doing the test there isn't anything wrong.  It is the way it is. Make sure you take varying shots and at varying distances, too.

EB
EOS 1DX and 1D Mk IV and less lenses then before!
Avatar
click here to view the gallery
Announcements