cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Autofocus not holding

mforster86
Apprentice

Hi,

 

I have a Canon Rebel, I've had no problems with the lens that comes with it (18-55mm) but whenever I use the 50mm f/1.8 II lens it will autofocus when holding the shutter button partially but then when compressing fully to take the photo there is always a slight auto adjustment on the lens knocking it slightly off focus.  The only way I've been able to get around this is to autofocus then turn to manual focus on the lens before taking the photo.. which isn't ideal.

 

Any suggestions?

4 REPLIES 4

Waddizzle
Legend
Legend

Try setting the focus mode to One Shot.  The "AI" modes try to continuously update the focus until you press the shutter.

--------------------------------------------------------
"The right mouse button is your friend."

I'm not sure I entirely understand, do you mean changing it from multi shot to single shot? I can't see any settings for focus just white balance. The camera is a eos 300d

Strangely, I don't see how to set it when in P mode.

 

focus.jpg


@mforster86 wrote:
I'm not sure I entirely understand, do you mean changing it from multi shot to single shot? I can't see any settings for focus just white balance. The camera is a eos 300d

Good point.  What shooting mode are you using?  Try full AUTO shooting mode, as a test.  If the camera beeps when it focuses, then you are in One Shot mode.

--------------------------------------------------------
"The right mouse button is your friend."
Avatar
click here to view the gallery
Announcements