Showing results for 
Show  only  | Search instead for 
Did you mean: 

TR8520 won't scan after upgrade MacOS to 11.1 (Big Sur)


Had problems with printing and scanning, but solved (I hope) the printer problem.

When attempt to access scan function from System Preferences -> Printers & Scanners->Scan->Open Scanner get message "Failed to open a connection to the device (-21345)"  If connect printer to Mac then click on Open Scanner scanner will run single scan.

Worked fine under Mojave.  Not sure under Catalina, May have worked under original Big Sur and maybe 11.0.1 but definitely does not work under 11.1.  I added IJ Network Device Setup Utility and it says Printer is OK and test print works.  I attempted to install latest Firmware as of Nov. 2020, but it says already have Firmware v. 1.100 installed.When I looked for more recent drivers and other software first got message none for "Catalina (detected)" so Canon doesn't even know I'm running Big Sur.


What do I need to do to get my scanning function back?  




Catalina was the last OS ceritifed for the TR8520.


You can try contacting Canon ,but I don't think its going to help.  At this point, you will need to wait for updated drivers or downgrade to a supported OS.  

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Thanks shadowsports.  I really appreciate you taking the time to reply.


If you are right my option is to wait, since I cannot downgrade the OS.  And wait is not acceptable.


I have Mac running iOS Big Sur v11.1. My HP printer finally died so need to get a new printer ASAP. I am thinking of getting Canon Pixma TR8520 based on reviews. But Canon Drivers & Downloads page for this model says "There is no driver jfor the OS Version you selected. The driver may be included in your OS or you may not need a driver." I'm not inclined to purchase based on a "maybe". Based on this string in user community, and as of this date, my takeaway is that TR8520 doesn't work/doesn't support iOS Big Sur. Is my takeaway correct?  

Hi TysonsDad,


There are no drivers available because the PIXMA TR8520 uses the built in printing system (Airprint) of the Mac OS.


The PIXMA TR8520 is fully compatible with Big Sur.





Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Mine sure isn't working. Printer works from iPHone 12 but printer nor scanner work with MacBook Pro running Big Sur. I have no idea what to do.

Why is my system, running Big Sur 11.2.3 not working with my printer then? What could be wrong. iPhone 12 works with printer. 


I'm running Big Sur 11.2.3. I can print to my PIXMA TR8520, but NOT scan. I've tried direct scanning using a USB, too, and this isn't working either. Since there are no drivers, what is the problem? I've also tried to download the IJ Scan Utility Lite, but this is turning up the "Can't communicate with scanner" error message (pasted below). However, my wife's older 2011 MacBook computer IS ABLE to communicate with the scanner. Is only one user allowed to scan on the PIXMA TR8520? If not, why am I not able to communicatte with the scanner with my newer MacBook Pro running Big Sur?



Cannot communicate with scanner. Possible reasons:

- Scanner is turned off.

- (If using wired LAN connection) It is disconnected from wired LAN.

- (If using Wi-Fi connection) Signal strength is poor due to obstructions.

- (If using USB connection) USB cable is disconnected.

- Other software or another user is using the scanner.


Please check and try again.

Hi Jamo2002,


Please follow these steps:


1.  Click on the Apple in the upper left corner.


2.  Click on System Preferences.


3.  Click on Printers & Scanners.


4.  Click on the TR8520 one time.


5.  To the right, click on the Scan tab at the top and then click on the Open Scanner button below that.


Are you able to scan?  If not, what error code appears at the bottom?





Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

No error message pops up because the scanner won't open. It seems frozen. 

Frozen Scanner Window