cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error Message is saying "Type of print head in incorrect. Install correct print head

nanciemd
Apprentice

I have tried resetting , power off, cleaned head.

Still errror message.

 

Printer in Over 2 years old.

Do I just need a new print head??

 

thank you!

100 REPLIES 100

Already did the trouble shooting with tech support and we are going to retire our MX870! Best printer I have ever had!! Now I sure hope the MX922 is a keeper!! It will be delivered tomorrow. The bummer is that I have a total of 31 #220-221 ink cartridges from my MX870 that I can't use!!! BUMMER!!

Thank you and have a great evening!

jadmiral
Contributor

I have an MG5320. replaced printhead with brand new, genuine Canon QY6-0080 print head and message still comes up..."incorrect printhead"

HELP!

John

 

Hello.

 

Troubleshooting with our support group will be needed to narrow down the cause of your issue. Please contact our support group using the "Contact Us" link below for additional assistance.

This didn't answer your question or issue? Find more help at Contact Us.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

SteveU
Apprentice

I have also got same error message on a Pixma MG5550 - it suddenly appeared in the middle of print run.

 

Have tried re-starting printer.  I have removed and replaced print head (following 3rd party Youtube video) but to no avail.

 

Canon telephone support could not suggest anything else other than calling engineer (£££) of buying new printer.

 

Has anyone found any other solution?  My guess it is as small electrical contact problem or a software problem that is preventing the printer from recognising the print head.  It is very frustrating when otherwise the printer seems fine (and was happily printing when the error arose between sheets).

ciprianmp
Apprentice

My MX925 suddenly got the same error message yesterday, after successfully printing a 10x15 photo and trying to print a second one.

First original printhead was replaced with another original one a year ago (due to some weird double black lines printing).

With the new printhead which got this 1403 error, I tried all advices here, to no luck.

I put back the old printhead for testing only and it worked fine (except for the black thingy). No error at all.

Mounted back the new printhead, same error!

So it is something definitely wrong with the printhead contacts/chipset, not the motherboard or printer's frimware.

Now Canon, what can be wrong? What can suddenly change an original catridge into a different type/model to not be recognized nor accepted by the printer?

 

PS: Canon offers no warranty to new printheads, so I might have to buy a new one now. If that's the case, instead of a new printhead (3rd), I might go for a different brand (no HP anymore for me, so probably Lexmark is the last one to try).

I loved my MX925

 

Chinyikhong
Apprentice
How to solve my canon pixma MG5570 series always come out printhead error when I turn onthe printer, the canon logo appear then nothing after that "error "

Hello Chinyikhong,

 

Thank you for reaching out to Canon USA!

 

We suggest reaching out to our US-based technical support team for further troubleshooting. They're available by phone during the week at 1-800-OK-CANON (800-652-2666) from 10am to 10pm (ET), or anytime by email at http://Canon.us/ContactCF  

 

We look forward to hearing from you soon!

I just received this error today. I just changed the printer cartridges for the first time since updating to Windows 10. Not sure if this is the cause. I'm trying to print out tickets to a show tonight and the canon customer service # is Mon - Fri. Luckily I have a pdf on my phone, but this stinks. I've had this printer I don't know how long and it's been good but I guess I might have to get a new one- since it appears no one had posted here that their situation actually got solved. I'm thinking it's time to try Epson if this is how Canon is going to get us to buy new printers.

Hi tvasilovic! 

Thanks for joining and posting in the Canon Forums! 

The Forum is not intended for immediate help, but a place to allow for the Community to give you assistance and feedback. If are you in the United States and this is an urgent support need, please CLICK HERE to reach our friendly Technical Support Team. Our Technical Support team does provide support on the weekends via email. 

We hope this helps! 

nikkopt
Apprentice

I had this problem about six months ago (Pixma MG5550), i tried re-seating the head and even tried the head of a friend that has the same printer as me and nothing worked.

What did work for me was playing with the white flat ribbon cable that connects the head to the main board. Nothing fancy, i just pulled it a bit to either side, just played with it a bit (gently of course, so i couldn't damage it) and guess what, as soon as i lowered the cover, the error went away and it has been working since then. I didn't disassemble the printer, just did it with the cover up.

Could it be that the problem that plagues everyone is actually a defective (or just making a bad connection) cable?

Avatar
click here to view the press release
Announcements