cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon i850 printer. I replaced the waste inkpads and now it will not power on. What do I do?

tyl604
Contributor

Canon i850 printer.  I replaced the waste inkpads and now it will not power on.  What do I do?  Is there a reset  button or could I have knocked something loose inside?

 

Is there a fuse inside?  If I remove the plastic case again, is there any reason I could not plug it in without the case?

 

Thx.

3 REPLIES 3

Patrick
Product Expert
Product Expert

Hi tyl604,

 

It is recommended that you contact live technical support . There is NO charge for this call. Real time feedback of a live technical support call would be very beneficial in this case.

Please dial 1-866-261-9362, Monday - Friday 10:00 a.m. - 10:00 p.m. ET (excluding holidays). A Canon technical support representative will be able to resolve this issue faster.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

tyl604
Contributor

Well, I found the answer.  I had forgotten to plug in the multi-pin connector under the printer when I placed it back in the plastic case.

 

So the power comes on now.  However I am getting four orange flashes ( which means that one ink cartridge is completely empty) and the cartridge cart will not slide back and forth - it is not moving.  Not sure whether I only need to replace the empty cartridges or whether there is a problem with the sliding mechanism.

 

I did get an email from Canon which suggested I call their technical support for a free conversation and that is much appreciated.  Will wait until I replace the ink cartridges to see if I still need to make a call.

Solved this too.  I left a piece of plastic inside when I buttoned it up and it prevented the carriage from moving.  Removed it and everything works now.  Also realigned the heads for the first time since probably 2002 and it is printing really well.

 

 

Avatar
click here to view the gallery
Announcements