Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't print to my PIXMA TS5020 using a USB cable


Hi Community,

I got a PIXMA TS5020 printer as a gift that unfortunately has been problematic from day 1 trying to get it to talk to my network and computer.  It prints maybe 1 out of 20 attempts, saying its not connected to the network.  Or my computer can't 'find' the printer.  Granted, my MacBook Air is super old, but it was able to download the driver software.  And it works for everything else I need it to, so am not ready to replace it. I finally gave up and got the USB cable thinking I could print directly from the computer to the printer.  Tried it today and my computer print queue says "The printer is not connected".  I've turned the printer off, counted to 30 and turned it back on.  I've rebooted the computer and replugged in the USB cable into both ports.  I've cleared the printer queue.  Nothing.

Any ideas?  Please help!  Thank you.  🙏



Hi, TechLuddite!

So that the Community can help you better, we need to know exactly which version of macOS is running on your MacBook Air. That, and any other details you'd like to give will help the Community better understand your issue!

If this is a time-sensitive matter, click HERE search our knowledge base or find additional support options HERE.

Thanks and have a great day!


Hi Danny,
Running MacOS 10.12.6.  Thanks.

Product Expert
Product Expert


When you go into system preferences and select add printer, does the printer have both a TS5020 ij network and USB option listed? 

Also, for the wireless issue, please click HERE for the steps to print the network settings. Once the network settings print, please let us know what the signal strength is listed. 

We look forward to your reply. 


I added the printer, after almost 2 hours on the phone with Canon Customer Support, including network strength testing and etc.  They were stymied by the situation as well.  But once the printer was 'installed' (and deinstalled and reinstalled several times), we left it there.  Its only worked rarely since then, so I moved it my husband's work office, and decided to try via USB cable instead of wirelessly.  Now that we're on a new network entirely, I've given up entirely trying to move over to a new network and hoped to be able to print only via USB.

If I delete the printer and then try to add it again, I'm afraid I'll lose everything on my (old) mac and have to start from scratch.  So, I can't "see" if there is a USB option listed.  Do I need to do that anyhow?  Totally confused about the core issue, since I have the driver info installed, the printer-laptop has printed in the past (albeit sporadically at best) and the USB cable is now plugged in to both my laptop and the printer.  Help me, Obi-wan 🙂

Enter for a chance to win