Canon Community Canon Community
 


Reply
Highlighted
Occasional Contributor
Posts: 11
Registered: ‎07-27-2017

C100 - Camera will not produce an image

[I accidentally posted this in the wrong EOS topic previously]

 

Flipped on my C100 today to test some monitors and there was no image in the viewfinder.  I tried on both AC and Battery power.  I checked the HDMI output.  I switched lenses.  When the camera is in 24p I get an image like the picture that I've attached.  (This is a frame grab from a recording I made with the camera). 

 

C100_Lines.png


I last used the camera a couple weeks ago and it was fine.  It has been in the Pelican Case securely nestled in foam.  I just flipped it on and got what you see here.  I tried flashing the Firmware to the latest, it was successful but made no difference.  When I flashed the firmware the settings reset and in 60i, instead of the image in my attachment, I got a full black screen with moving horizontal green lines.

 

Do the sensors just crap out like that?

Product Expert
Posts: 75
Registered: ‎07-03-2019

Re: C100 - Camera will not produce an image

Hi Spassvogel,

 

It's hard to say exactly what caused this, but from the looks of it your sensor is likely having some kind of issue since the menu system and other functions of the camera appear to be working without issue. I don't think there are really any at-home remedies for an issue like this so the best bet is probably to have it checked out at a repair facility.

 

https://www.usa.canon.com/internet/portal/us/home/support/service-repair

 

 

 

Occasional Contributor
Posts: 11
Registered: ‎07-27-2017

Re: C100 - Camera will not produce an image

 

Is there any ballpark figure at what a sensor repair would cost? 

 

Apparently I need to phone their support line before I can send it in. 

 

Anyway, thanks for the response.

Moderator
Posts: 2
Registered: ‎08-07-2018

Re: C100 - Camera will not produce an image

Hello Spassvogel,

Cinema level cameras, like your C100, would need to be inspected by a technician to receive a free estimate.  You can use the following link, for instructions on how to send the camera in for inspection: https://Canon.us/8wva5.  If you live in the western part of the U.S.A., you can use the link https://Canon.us/lv2xu. 

Occasional Contributor
Posts: 11
Registered: ‎07-27-2017

Re: C100 - Camera will not produce an image

 

I sent it into Canon.  $660 estimate to replace main PCB board.  I don't know if they actually pinpointed the problem or not, it sort of sounds like this is a fix-all.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement