Canon Community Canon Community
 


Canon USA EOS Webcam Utility – Windows Official Support/FAQ

by Community Manager ‎09-16-2020 04:53 PM - edited ‎11-11-2020 02:42 PM

EOS-WEBCAM-FAQ-OPTIC2 (1).png

*Verified Q&A comments that are commented below this artcile will be given a "kudos" from the official Canon U.S.A. account and added to the FAQ list below.*

 

Q: What are the supported Canon camera models for the official version?

A: In total there are 43 models -- refer to canon.us/livestream for the full list.

 

Q: What is the distribution for official version?

A: The beta version was only available in the USA. However the official version will be widely distributed in regions outside the USA. Please check the website of each country or region to see if it is distributed in your area, or contact your local service location.

 

Q: Symantec Endpoint Protection displays a warning during installation of EOS Webcam Utility.  What should I do?

A: EOS Webcam Utility setup.exe is signed by a valid digicert Extended Validation SSL certificate and it can be safely installed. Please hit "Allow this file" and proceed the installation.

 

Q: I want to use the software with high image quality. (I want to use FHD). 

A: The resolution using the software is generally 1024x576 when set to video mode.  Please note that this may vary depending on your camera model.

 

Q: Can I change the camera settings while the camera is connected to the computer with the USB cable?

A: Please perform menu operations without the USB cable connected. You can operate other dials and buttons even while video streaming with the USB cable connected. (The software does not have the functionality to change camera settings).

 

Q: Does continuous use of the camera generate heat?

A: When you don't use in-camera recording, the webcam functionality does not generate more heat than during normal shooting. But, if you use in-camera recording, it will generate the same amount of heat as during normal in-camera recording.

 

Q: Can I use the camera’s microphone?

A: No, EOS Webcam Utility software doesn't transmit audio through USB connection.Please use your computer’s built-in microphone or an external microphone separately connected to your computer. 

 

Q: What are the supported Windows Operating Systems?

A: Please refer to canon.us/livestream for the full list of supported Windows Operating Systems.

 

Q: What is the frame rate of the video stream?

A: The frame rate depends on the camera model, camera settings, PC performance and the transmission speed specifications of your PC and USB, etc., however in most cases it is up to 30 fps.

 

Q: Can multiple cameras be used with the EOS Webcam Utility software?

A: The software does not support streaming from multiple cameras simultaneously.

 

Q: How can I increase the output resolution on a USB Feed?

A: The resolution of the video stream through the USB feed cannot be changed. If you need a higher resolution output please consider utilizing HDMI options offered by your camera model, if compatible. Please refer to canon.us/livestream for information on clean HDMI output supported cameras offered by Canon.

 

Q: Does the EOS Webcam Utility Tool support 4K?

A: The software does not support 4K. If you need a higher resolution output please consider utilizing HDMI options offered by your camera model, if compatible. Please refer to canon.us/livestream for information on clean HDMI output supported cameras offered by Canon.

 

Q: How long can I stream using the EOS Webcam Utility software? Is streaming limited to 30 minutes?

A: The streaming is not limited to 30 minutes and you can stream until the battery runs out. If you want longer usage please consider an AC adapter and DC coupler as an option. Depending on the camera temprature, camera will automatically shutdown to protect camera device. To prevent overheating it is recommended to set the video resolution to 1080p.

 

Q: How can I sync the video and audio, or reduce the lag between video and audio?

A: EOS Webcam Utility does not control the sync of video and audio.

 

Q: Why do I get the EOS Webcam Utility logo in reverse or a black screen, on my video feed?

A: If the previewed image (EOS Webcam Utility logo) on the video feed is mirrored will depend on the video conferencing or streaming application you are using. When you see a black screen it is most likely because EOS Webcam Utility is in use by another application. You can either close the other application or deselect EOS Webcam Utility in the other application to restore the video feed.

 

Q: What if my camera isn't listed but I tried it and it works?

A: The list of supported cameras includes the cameras that have been tested with the software. We cannot guarantee functionality of the software with a camera not included on the list.

 

Q: Can the software work via HDMI connection?

A: EOS Webcam Utility software does not support HDMI connection and only supports USB connection. Please check our website for cameras that support clean HDMI output and how to use them.

 

Q: Why do I see black border in my video feed?

A: When the camera is set to "Still Photo" shooting mode, black side pillars may appear to the border around the video source image. We suggest that you set the camera to "Movie" recording mode. Note: Some selected cameras may still display black side pillars bordering around the video source image, even if set to "Movie" recording mode.

 

Q: Is it possible to internally record video while streaming?

A: Yes, recording while streaming is supported.

 

Q: Is there are an internal record time limit while streaming?

A: Recording time while streaming and recording is limited to the cameras video recording time specification.

 

FIND THE RIGHT WEBCAM STARTER KIT

products-v2.png

Whether connecting with colleagues, academic peers, or family and friends, find the right webcam starter kit that works for you.

button-shop-now.png

Comments
by
‎01-11-2021 02:46 PM - edited ‎01-11-2021 02:53 PM

I have used the EOS Webcam Utility with my EOS R and it worked great. I have since sold my R and upgraded to an R5. I am now trying to use it as a webcam with the EOS Webcam Utility.

 

First, I make sure I'm in video mode and I set the camera to 1080p/29.98 fps, then I set my shutter speed to 1/60. These are the settings that worked on my R. 

 

Then I connect my camera to my laptop's USB Type-C port. When I open Zoom (or any other webcam software) and set the camera to EOS Webcam, it works.

 

However, after only a few minutes the image goes black with the inverted EOS WEBCAM UTILITY text on the Zoom screen. I can get the camera video working again by disconnected the cable and/or restarting the R5.

 

How can I get the EOS Webcam Utility to work continuously?

 

I downloaded the latest version of the EOS Webcam Utility from the R5 support page and that didn't make any difference.

by Aron Duby
on ‎01-11-2021 08:26 PM

While using this for a live stream the video freezes, turning the camera off and on again kicks everything back into action. I was using this with OBS. The OBS logs didn't show any issues. But when I open up the windows event viewer I can see EOSWebcam errors corresponding to the times it froze. Its the same 2 errors, back-to-back within 5 hundreths of a second

 

First error: OpenSession Err: 2

Second Error: OpenSession New Err: 128

by James Collins
on ‎01-13-2021 09:14 PM

Firstly, TY to Canon for making this capability available, I've upgraded my ancient Canon Rebel camera body to a Canon Rebel T7 primarly because of this new capability.


I've noticed, and it's been reported (https://www.reddit.com/r/canon/comments/ih7857/auto_focus_not_working_in_video_modewebcam_mode/), that AutoFocus does not appear to work for the Rebel T7 when using it in video mode + webcam utility, regardless of how the AutoFocus is set on the camera and the lens.

 

I would like to know if the lack of AutoFocus when using the Rebel T7 as a webcam is a limitation which Canon expects to overcome in a future version of the Webcam Utility? Or is this a limitation of the Rebel T7 camera body which is impossible to overcome?

 

Thanks.

by
on ‎01-13-2021 09:38 PM

As it was reported by another user of the forum, I'm also getting an error 70 occasionaly on my EOS 80D while using the driver. I cannot tell for older versions of the driver since 1.1 is the first one that I tried.

 

I did notice that the Err 70 message was occuring more when my lense was zoomed to a certain level. For example, I am using the 18-135mm lense that came with the 80D. When at 18mm f/3.5 the driver seems to be stable, but when using it at 24mm f/4.0 then it will show Err 70 after 1 or 2 minutes.

 

Any help would be appreciated. Thanks.

by ofek sh
on ‎01-17-2021 03:00 AM

Please consider supporting 2 or more cameras. It will be very useful.
My intention is to make it possible to put in OBS 2 video sources that each camera has a different source

by Canon DSLR EOS 250d
on ‎01-20-2021 01:59 PM

Hello, i was wondering if you had any information that could help me use my Canon DSLR EOS 250D as a webcame? 

 

Cheers

by ThatGuyRyan
on ‎01-22-2021 06:54 PM

Just another 5D Mark II owner looking to find out if there is any hope of continuous autofocus while using this utility being available.

 

If it will never be supported could that be stated now so we can look into alternatives?

 

Very frustrating to find out the camera is now supported, but not really.

by bsiever
on ‎01-28-2021 03:17 PM

Hi, 

 

I'm using macOS (Catalina 10.15.7) and EOSWebcamUtility 1.0.4.0 with an EOS 77D which is plugged in (not running off batteries).  I am using a USB extension cable and it's connected to a Thunrderbolt display, which is connected to a MacBook Pro.  The same hardware setup has worked pretty reliably with Camera Live (https://github.com/v002/v002-Camera-Live)

 

I've got two questions:

  1. Are errors dumped anywhere specific?  I see some in /var/log/system.log.
  2. The Camera seems to "stop" after about 10-30 minutes and the picture shown is an EOS splash screen (EOS Webcam Utility with a red x over a USB cable icon).  It seems to work ok again as soon as I unplug and replug the USB cable.  Just deselecting the camera source and reselecting it isn't enough --- It has to be unplugged.  Any suggestions for what the problem is or how to overcome this?  

Thanks for any info,

  Bill

 

by Armin Kamran
on ‎01-31-2021 04:04 PM
Hello. I have cannon EOS 700 D.
Please
Please
Insert the EOS webcam of this model
by Don Nielsen
on ‎02-01-2021 12:56 PM

I was able to use EOS Webcam Utility Beta just fine with my EOS RP. I deleted that to install 1.0 and now it does not recognize my camera at all. When I select EOS Webcam Utility as my camera in (Zoom) I get the black logo that says "EOS Webcam Utility"  with a red triangle/! over the camera icon. Can I have beta back until you fix this broken mess?

by Niall G
on ‎02-03-2021 03:36 PM

Just a question on the list of compatible cameras, are you planning to expand it at all or is it complete?

 

I have this absolute relic from ages past: https://www.canon.ie/for_home/product_finder/cameras/digital_slr/eos_m/specification.html

It still works perfectly and I was hoping to use this as a webcam as I don't use it for much since getting my DSLRs and it's small enough that it doesn't take up much room on my desk. One of the most versatile, affordable little cameras I've ever used, don't know why you discontinued it, it's a gem. 

by
on ‎02-05-2021 11:26 PM

I updated Windows 10 yesterday to version 2004 (as shown in 2nd screenshot below.)

Since the update, neither my EOS 40D nor EOS 90D will connect.  They were working fine until the update.

 

I'm concerned about the message "There are no compatible drivers for this device".  I have uninstalled and reinstalled the EOS Utility and EOS Webcam Utility.  I have rebooted multiple times, checked for latest drivers, and tried everything else I can think of.  (Reverting Windows 10 to version 1903 is not an option.)

 

Canon_driver_failed Windows 10 update

 

Windows version

 

Thanks in advance for any advice.

 

by GetWise
on ‎02-06-2021 01:51 AM
Will y’all be adding power canon powershot sx50 hs? Trying to find any buy a canon is hard. Best Buy is completely sold out I even tried to buy the one on display..
by Ayrillyn
on ‎02-13-2021 06:46 AM

How do i autofocus my eos t7 while streaming? I want the camera to refocus as I move but I can't press the shutter while im streaming. I have it in movie mode and im using a canon lense as well.

by Product Expert
on ‎02-17-2021 07:19 PM

Hello Ayrillyn,

 

The EOS Rebel T7 is unable to actively re-adjust the focus while you are streaming, so to adjust the focus you would need to press the shutter button down half way. I see you mentioned you're unable to do that, but unfortunately that is a limitation of the EOS Rebel T7. 

 

One thing you could do to make that easier would be to set the camera to the face tracking AF method. In that mode the camera is constantly looking for faces, and as long as your face is in the frame you could press the shutter button half way and the camera will refocus on your face.

 

To set the focus mode put the camera into movie mode and press the Menu button. Go to the fourth red camera tab and choose AF Method. Select the Live Mode option with the smiley face.

by
on ‎02-18-2021 09:54 PM

Hello Canon Staff,

 

As I reported over a week ago above (permalink 02-05-2021) the Canon Camera Driver is failing to load in the most recent Windows 10 update.  US-based product support worked with me on the phone, but was unwilling to escalate this issue to the Engineering teams in Japan, because it "worked for him" on another Windows 10 version.

 

I can't easily revert this Windows update, and the driver failure is blocking my work.  Can anyone confirm if there is a driver workaround for camera connection on Windows 10 Build 2004 (19041.746)?

 

Thanks in advance for your time and assistance.

by
on ‎02-18-2021 11:53 PM

Hello Canon Support

Is there a way to replace the Canon Offline image by another photo? Its not a good experience when our viewers see this during the livestream

q639rkbzxzv51.png

by Product Expert
on ‎02-19-2021 06:20 PM

Hello DavidJMarks,

 

I'm sorry to hear the EOS Webcam Utility is not working after the recent Windows update. Our engineering team do review all the notes for EOS Webcam Utility calls, so they will be receiving the notice you sent them. I have sent an alert about it as well. Looking at the notes from your calls most of the trouble shooting was already tried, but there are a few more things that could help.

 

The first is to make sure your EOS Utility is fully closed before starting your webcam software. When the EOS Utility and the webcam utility are both on at the same time it prevents the webcam utility from detecting your camera. That is because when they're both open at the same time they both try to use the camera at the same time. When you close the EOS Utility check your system tray as well. Sometimes it can still be running in the background.

 

It would also be good to take the memory card out of the camera, connect the camera and computer, and check to see if the same thing is happening. Sometimes computers will detect the memory card and will cause the same kind of conflict the EOS Utility causes. Connecting the camera without a memory card in it would prevent that from happening. The EOS Webcam Utility does not need a memory card to work, so it will not cause an issue with that portion.

 

One more thing to do is to make sure your camera is set to Movie mode. Sometimes if the camera is still in photography mode it can cause connection issues.

by
‎02-19-2021 08:35 PM - edited ‎02-19-2021 09:07 PM

Thanks @Hazel_T for the response.

 

I have a 40D and 90D which can both connect to other Windows 10 systems (running the earlier, non-updated version) without issues.  Both also worked on this system prior to the update to version #2004.

 

Note that it is neither the EOS Webcam Utility nor the EOS Utility that is failing, but rather the Canon Camera USB DRIVER that fails to install.  This means that the camera is not recognized at all by Windows now. 

I realize that this forum is for the webcam utility, and not the driver, so I also posted to the Software forum.  That discussion has gotten some traction (permalink to other thread) and there was a suggestion that I may need to update the Media Feature Pack, because the specific Enterprise N edition is missing some media support to comply with international rules. 

by
on ‎02-24-2021 03:04 AM

downloaded everything, site said at the time that my 80D is compatible but on OBS and Discord, I see nothing but the logo.

by Product Expert
on ‎02-24-2021 06:05 PM

Efrain.JPG

 

Greetings, Efrain

 

If the EOS Webcam Utility title with a red "X" and a symbol of a white USB cable is appearing in OBS or Discord, then it may be an issue with the USB connection between the camera and your computer. Please check that your cameras USB cable is properly connected both the camera-side and the computer. I would also suggest to have you check the battery or power adapter that provides power to the camera. Let's also make sure that your camera is powered on.

Let's also check to make sure that the wireless feature on the camera is disabled. If Wi-Fi is enabled, even if it's not currently in use, it will disable the USB port on the camera.

We would recommend to connect the camera directly to the USB port on your computer in case you are using a USB hub where different devices connect to the computer. If possible, try testing a different USB cable and a different USB port on the computer.

If you're seeing the EOS Webcam Utility title with an icon of a white camera with a red triangle, then it means that the camera's LiveView function and video signal is being used by another appliction or software.

We would recommend to exit and close any applications that may be running on your computer, or in your task tray that may be connected to your camera, or using the camera’s LiveView video signal. For example: Canon's EOS Utility or an application connected to the camera like another video conferencing app.

 

If you are still experiencing issues with running the EOS Webcam Utility, please feel free to reach out to our phone support team. They can be reached at 1-800-652-2666, Monday through Friday between 9:00 am to 9:00 pm ET and Saturday between 9:00 am to 7:00 pm ET.

by ShawnJ
on ‎02-26-2021 10:48 AM

Which Canon cameras support autofocus while using the webcam utility?

by JordanS
on ‎02-27-2021 08:53 PM

Hello, Starting this month the utility has not worked. It has constantly given me the esos webcam utility with the camera and red triangle. There is nothing else using it, and I've checked in the background. I do not have the eos utility that would be the issue installed. It is a 60D that is supported but does not have wifi, so that is also not the issue. Please let me know what is going on? I've tried multiple cables, and it's the same problem each and every time. I'm even running it without the SD card without success. I need this for my job, and it's just not working. Whatever has happened in the last month, or if it just needs an update, or an update to the drive, but it's not working. I've read above and I'm not the only one experiencing it. Please canon actually acknowledge this is an issue, and help us, because this is beyond frustrating, and you're pretending it's not happening. 

by
on ‎03-01-2021 01:31 PM

Hey guys, i was getting an error screen with a cable sign with a red X on top of it. After a couple of days trying to figure it out, i noted that my wifi was activated on the camera. Turned it off, rebooted the camera, and it worked. If you are having the same problem, give it a try. Good luck!

by Product Expert
on ‎03-02-2021 06:06 PM

ShawnJ.JPG

 

Hello, ShawnJ

 

The Canon cameras which support continuous auto focus while in the video mode and when used with the EOS Webcam Utility would be cameras that have the Movie Servo AF feature. When accessing the user guide for a Canon camera which is on the list of compatible cameras for the EOS Webcam Utility, the Movie Servo AF feature will be listed in the video recording section of the user guide. If this feature is not listed, then the Canon camera does not support continuous auto focus in the video mode.  For example, the EOS Rebel T7 does not provide continuous auto focus in the video mode but the EOS Rebel T7i does since the EOS Rebel T7i is the more advanced version with more features.

by madpaddler
on ‎03-02-2021 11:03 PM

I had the Canon Webcam, Beta Version, and it worked fine on my Windows10 PC with my 6D mk II. 

 

However, when I upgraded to full version, it did not work.  Long story short, I spent three (3) whole days working on this issue.  I called Canon Tech Service twice and each time we spent over an hour trying to fix this problem with now results.  They REALLY tried, and I hope they see this comment, as I was able to track down the problem due to a comment one of them mentioned, which was that something might be blocking the Webcam Driver from working.

 

I have Norton 360 and System Mechanic Ultimate Defense 21.0.1.46 on this PC.  Tonight I went into the All Programs/Apps/Camera, with my 6D mk II turned on.  When I selected the Camera App, the EOS Webcam came on... as it should.  That told me that the problem was not in the Webcam Driver, or Camera. 

 

I then went into Systems Mechanic Ultimate Defense/Privacy Guardian/ Privacy Shield/Camera Access/ and found that it was NOT turned to ALLOW.  I changed that setting and restarted the computer.

 

That fixed it!  Thank You Canon Tech Support.

 

 I hope this will be of help to others.

 

 Madpaddler

by trubeleafer
on ‎03-03-2021 04:25 PM

PLEASE PLEASE PLEASE PLEASE PLEASE include the EOS M100 in this application!!!! I just bought it not knowing about this webcam utility. It's such a nice camera and perfect for all other uses I have for it. I'd love to use it as a webcam too. PLEEEEEEASE! Also, canon cameras ROCK! keep up the good work.

by Gerry OBrien
on ‎03-07-2021 08:36 AM

I just spent several long minutes detailing my inability to get the Webcam Utility to work with my 5D IV and my workstation class computer, and since a Windows 10 update, my Surface Pro note book, too.

 

And of course this website deleted my comment and kicked me out when I tried posting it.

 

Thanks so much, Canon.

by
on ‎03-09-2021 04:59 PM

(I posted this also in the other forum, but figured I would try this official support page as well)

 

Hi. I have a very strange problem. The webcam utility was working for me but one day just quit working. The strange thing is that the regular "EOS Utility" DOES work and I can even see live video with it. But when I try to use the webcam utility I only get the red triangle now, no matter what I do.

 

Yes, I completely shut down EOS Utility, even the tray icon. It makes no difference. 

 

I am using version 1.1 for Windows 10 Pro with an older EOS 60D. 

 

Things I have tried:

 

- Various applications: XSplit Broadcaster, OBS Studio, Skype, Google Meetings

- Different USB cables (even though it was working before)

- Restarting the computer, camera, unplugging & replugging, etc.

- Rerunning the Webcam Utility installer and choosing the "Repair" option

- A different computer which does not even have the normal "EOS Utility" installed on it (to rule that out as a conflict)

 

Now I did use the camera to take some still pictures and after that it is when it quit working as a webcam, but I don't see how that could be relevant. I switched back to video mode, of course. Nothing seems to work.

 

Anyone have any ideas?

 

Thanks.

by Marios
on ‎03-13-2021 05:25 PM

Hey! I downloaded and installed Canon Webcam Utilities and I have issues with the following error.

 

by timo0815
on ‎03-16-2021 06:57 AM

Please add EOS M100 to the list. Thank you!

by SMN
on ‎03-18-2021 03:19 AM

WEBCAM UTILITY DOESNT WORK WITH SKYPE FOR BUSINESS! Smiley SadSmiley SadSmiley Sad

Please fix it. Skype for Business crashed all the time. Smiley Frustrated

 

Using 5D Mark II, work fine for me in any other program like normal Skype, OBS, Google Meet etc...

 

by er0c
on ‎03-30-2021 02:54 PM

 "eos webcam utility"  does not appear under any of the cameras listed anymore??  where are you guys even downloading this from?

by Marius Ion
on ‎04-16-2021 01:42 PM

Hi,

 

I have an Canon EOS 80D camera and I have some questions of which answers, I think you should add to the FAQ list:

 

If the camera is used with the webcam utility:

 

Does the sensor wear out when using the camera as webcam / Will this impact image quality over time?

Is it increasing the internal stutter counter ?

Will it stop after 30 min ?

Do you have plans for linux support ?

 

Thank you in advance!

by Product Expert
on ‎04-16-2021 06:09 PM

Hi Marius Ion,

 

Thank you for your questions. The EOS Webcam Utility uses a lower resolution to help prevent it from wearing out the sensor or impacting image quality. The EOS Webcam Utility will not impact the shutter count. The shutter count will only go up when the shutter assembly goes through the motion to take a photo. The EOS Webcam Utility does allow the camera to continue outputting video beyond 30 minutes. At this time Linux is not an operating system the EOS Webcam Utility is compatible with.

 

We appreciate feedback on updates customers would like to see for our software. We have a team that documents and handles customer feedback. I have already alerted them to this email, but if you want to contact them directly in the future they can be reached by going to our website HERE and selecting Feedback in the top left corner of the site. We do take customer suggestions and feedback into consideration when we are updating our products and processes.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement