cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Webcam Utility disappeared with Sonoma 14.1

MustyDisregard
Apprentice

Hello!

I recently updated my Mac to Sonoma 14.1 and I no longer see the Webcam Utility as a camera. This occurs in Zoom, OBS, and Photo Booth. I tried uninstalling the Webcam Utility, rebooting, and re-installing (with the requisite reboot).

Macbook Pro M1
Sonoma 14.1
Webcam Utility 2.0.30
EOS R6

Edit: Interestingly, Webcam Utility Pro sees the camera and displays what the camera sees (eyewink reported this first, and I'm seeing the same).

Please help

1 ACCEPTED SOLUTION

Via the above reddit link, https://support.apple.com/en-us/HT213969 solved the problem for me.

Edit: Linked to the official Apple page, and Engrish.

View solution in original post

9 REPLIES 9

frdarryl
Apprentice

Me too. Canon M50, in my case. 2018 Mac Mini with the 8th gen Core i7.

eyewink
Apprentice

Me too. MacMini M2 with Sonoma 14.1.
Utility Pro sees the camera and the picture, but other programs do not show the EOS Webcam Utility in the Camera list... 

Via the above reddit link, https://support.apple.com/en-us/HT213969 solved the problem for me.

Edit: Linked to the official Apple page, and Engrish.

Thanks; that worked!

Hopefully Canon can update their software soon.

Hazel_T
Product Expert
Product Expert

Hi MustyDisregard,

I'm sorry to hear your camera isn't getting detected correctly. At this time the EOS Webcam Utility has not been updated for OS 14 Sonoma, so it might not currently run correctly on that operating system. At this time there is not an estimate for when an updated version may be released.

One thing you could try is uninstalling the EOS Webcam Utility, restart the computer using the option in the operating system, and then do a fresh install. Sometimes if the software was already installed when the operating system was updated it can cause issues like this. The current version is available HERE. Once you are on the web page click on the Software & Drivers button, click on the OS version drop down, and select macOS Venture v13. The current version is EOS Webcam Utility Pro 2.0.30.

I find this answer and the general state of Canon's software to be disappointing (I had a bunch of problems with an older Intel MacBook Pro and the Webcam Utility not showing a feed from my camera).

I glanced at your reply history and noted that you claimed Apple doesn't provide copies of pre-release Mac software as the reason it hasn't been updated. This is untrue! Apple has had a beta/preview program (now at https://beta.apple.com/) literally for decades now. And it's evidently free (https://beta.apple.com/faq).

Hi Hazel - has there been any progress on a software update? I can't use the recommended fix since my computer settings are managed by my workplace.

This is the recommended fix for now - Canon USA is currently working on an update to the EOS Webcam Utility; however, we are unaware of a specific timeline for when said update might be made available to the public. 

If you don't have the ability to perform the workaround as prescribed in the Apple Support Article, you may want to reach out to your company's helpdesk or IT to see if they can help. 

Avatar
click here to view the press release
Announcements