Showing results for 
Show  only  | Search instead for 
Did you mean: 

Rebel T6 and EOS Webcam Utility - Unable to Use as Webcam


The Canon EOS Webcam Utility has gone from the easiest, best to use camera webcam software I've ever experienced, to a broken, buggy, glitchy mess that flat out does NOT work.

Ever since the Pro version came out, I am completely unable to use my T6 as I had done for over a year.  I am trying like heck to get it to work in OBS, and every time I think I have it solved, the camera feed goes away and it crashes several pieces of software.

I have reinstalled the software probably a dozen times now, and I have used as many youtube tutorials as I can stomach.  I have reinstalled the camera drivers, installed the  MTP USB Device driver, ran the software, closed the software while trying to use it in OBS, etc etc etc.  It does not work.  Period. 



Hi, criticalheatflu!

So that the Community can help you better, we need to know exactly which operating system is running on your computer (i.e. Windows or macOS, and which version thereof). That, and any other details you'd like to give will help the Community better understand your issue!

If this is a time-sensitive matter, click HERE search our knowledge base or find additional support options HERE.

Thanks and have a great day!

Windows 10, up to date. i7 7700k CPU, 16GB RAM, 1060 6GB GPU.

Tried USB 3.0, 2.0, external Hubs. All fail the same way.  All used to work flawlessly.

Your own program refuses to even recognize the camera.  I youtubed a tutorial about changing the driver to the MTP USB Device, which I thought fixed it.  However, it would then work for about 10 minutes and then lose the picture again.  After that happens, your program would lock up if I tried opening it, and then other things such as OBS will freeze as well.

Reverting back from the MTP USB Device nonsense, the camera just refuses to get recognized by the software at all.  All I'm met with on any program I have (OBS, your own software) is the "EOS WEBCAM UTILITY" screen.  However, on my device list in the Windows Control Panel, the camera is, in fact, there.  There is absolutely zero reason that your own software shouldn't be able to recognize it given my PC sees it just fine.  Even calls it the Rebel T6 Camera.

Again, prior to this pro version coming out, everything worked as it should.  It was truly plug n play.  I was able to use my camera without a single hiccup for well over a year, streaming, recording, doing business calls, etc.  I loved it and thought the world of it.  But now, I'm left scrambling trying to get the funds together for another expensive camera to suit my needs.  Please advise.



The following statement is vague, “It doesn’t work.”

Help someone to help you.  Tell us how to reproduce your issue.

Questions:  Does the regular EOS Utility still work with your USB cable?  What type of computer are you running, PC or Mac?  What OS are you running?  

If this us a PC that you built yourself, then what chipset are you running?  Are you aware the Microsoft recently released a mandatory update to Windows 10? 

I believe the update was pushed beginning on May 12, 2023.

"The right mouse button is your friend."

I provided OS and hardware information in my previous reply.

Windows 10, which is up to date.

Intel i7 7700k CPU

Nvidia 1060 6GB GPU

I'll have to see about the mobo  when I get home.

When I say it doesn't work, I'm saying the camera does not get recognized by the EOS Webcam utility and shows no video.  Sometimes, with a reboot, I can get the feed to show, but then it goes away in about 10 minutes and will not come back. Sometimes software such as the EOS Webcam Utility or OBS will freeze when this occurs.

Also, I'm referring to the EOS Webcam utility.  Is the EOS Utility different? If so, please enlighten me on the differences between the apps.