cancel
Showing results for 
Search instead for 
Did you mean: 

Rebel SL1 Not Working with EOS Webcam Utility

nathanjlong
Apprentice

Hi - I've seen a few posts with similar issues, but they seem to fizzle out before a solution is figured out.  Hoping to get this resolved.  I cannot get the EOS Webcam Utility to work with the Rebel SL1. On Zoom and Discord, it just shows black (no EOS Webcam Utility Logo) and on my camera it shows the little computer logo on the screen. On Zoom and Discord, it does say the camera in use is the EOS Webcam Utility. My camera is on Video mode - On the Rebel SL1, the video mode is on the same selector switch as Off and On, which seem different that other models. It goes Off-On-Video. I've read posts and watched a few Youtube videos and feel like I've tried all the suggested fixes including making sure EOS Utility is disabled/closed when the camera is connected, I've uninstalled both the EOS Utility and Webcam utility and done fresh installations, tested my cable using the EOS Utility to control on the camera and it displays the feed from my camera to my PC fine, LENS CAP IS OFF 🙂 Kinda out of ideas on this one and hoping for some help! Thanks

4 REPLIES 4

Waddizzle
Legend

It sounds like you are using a Windows PC.  What version of the Windows OS are you running?

Are you able to use the conventional EOS Utility to connect to the camera?  This is a good test of the cable, USB port, and the camera.  I do not recall if the SL1 has Wi-Fi, but make it is disabled and the camera is set to use the USB port for communications.

Another crucial step many people overlook is disabling the EOS Utility Launcher Service.  If you see the camera icon in your system tray, then you need to right-click on it, and select EXIT.

--------------------------------------------------------
"The right mouse button is your friend."

I’m using Windows 10. I am able to use EOS utility to connect to and control the camera. I can see the camera feed on my screen in EOS Utility so the USB cable and port I’m using is working. SL1 doesn’t have WiFi. I have made sure EOS Utility is closed. 

Waddizzle
Legend

You also need to make sure the EOS Utitlty Launcher Service is not running.  

If you can see the Canon EOS Utility icon in the System Tray, then it is still running.  Right click on the icon, and select “Exit”.  Do this before connecting the camera to use the Webcam Utility.

--------------------------------------------------------
"The right mouse button is your friend."

Yes I make sure the system test icon for EOS utility is closed before connecting the camera

Announcements