Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Webcam Utility - shuts off then on every 30 minutes


I have a Canon 7D Mark II and a Macbook running MacOS 10.15.7 running the 1.1 release of the EOS Webcam Utility.  I have the camera setup as a webcam and works great except for one new behavior.  If I'm in a meeting longer than 30 minutes, it'll shutoff almost exactly at 30 minutes for a couple seconds and then reconnect.  It sounds like it is power cycling.  In the Setting menu I already adjusted the Auto Power Off to disabled.  When I had the beta webcam utility, this wasn't happening.  Only really started noticing it after I updated it to 1.1.


Any thoughts on how to fix this?


Try setting auto power off to 1 minute.

View solution in original post


But how do you stop the screen displaying that no card is inserted?

Do you guys use video mode or AV, M etc.


was this ever resolved? having the same issue...

Not yet, going to test the auto power off set a 1 min to see if that works.  I did find that if I tap the shoot button it resets the 30 minute timer.  Kind of annoying since I have meetings that go over 30 minutes but it's a hack for now.  Still looking for a more permanent fix.

I just tested the set auto power off to 1 minute and that seems to have fixed it. Doing a few more tests to confirm.

I can confirm after 3 tests that setting auto power off to 1 minute fixes this issue. I have it on M mode, video shooting mode. Thank you bridge!!

Glad to hear that this worked for you too!

Me too! I’ve been researching this issue for over 2 months, you’re literally the only person on all the threads that had the solution. I owe you big time!

Impressive. Any one have an idea why setting power off to 1 minute works? It seems like that sets the camera to turn off every one minute, but somehow forced the camera to stay on. Cool that it works. Just curious as to why.

Great question. I don’t have any idea why it worked. I guess I just got lucky.

Great question. I don’t have any idea why it worked. I guess I just got lucky.

If I had to venture a guess as to why it worked, then it would be because the default setting is not disabled. One minute might be the default, I’m not sure.

It is a safe bet that the Webcam Utility has to make a number of assumptions about camera settings. The best assumptions to make would be settings are at their factory defaults. The same app seems to be used with a wide variety of cameras, each with their own set of menus and options.

"The right mouse button is your friend."