cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon EOS Rebel T7 & Canon EOS Webcam Utility Pro Software Not Working On Macbook Pro Monterey v12

ross3jn
Apprentice

I am having difficulties connecting my EOS Rebel T7 to the Webcam Utility Pro Software - it can detect for about 2 seconds at a time and then completely shuts off. My Macbook Image Capture detects the camera, and all of the other Canon software detects my camera, so it isn't my USB cable/hub that isn't working. 

Screen Shot 2023-09-16 at 2.32.29 PM.pngScreen Shot 2023-09-16 at 2.32.11 PM.png

I already tried to look up solutions, but it seems that all softwares should be able to be utilized on my M1 processor. 

I am unsure what to do. Are Rebel T7's not compatible with the Webcam software anymore? It is just confusing because it connects for 2 seconds from time to time...so there is some sort of connection there.

1 ACCEPTED SOLUTION

Anonymous
Not applicable

If you are attempting to update your camera firmware, put the .fir file from the firmware update file downloaded from Canon on a freshly formatted SD card and install in the camera. Chose firmware in the menus (while in P mode on the dial), and it will offer to update the firmware to the version on your SD card.

I don't think that the firmware will fix the communications problem, but you could try and see.

View solution in original post

4 REPLIES 4

ross3jn
Apprentice

So I updated my Macbook to Ventura v13 and redownloaded all of the software. Still doesn't work. OK...I'll try and update my firmware. 

And it loses connection every single time I try to update my firmware. I cannot do anything on this camera even though it is connecting. This is frustrating.

Anonymous
Not applicable

If you are attempting to update your camera firmware, put the .fir file from the firmware update file downloaded from Canon on a freshly formatted SD card and install in the camera. Chose firmware in the menus (while in P mode on the dial), and it will offer to update the firmware to the version on your SD card.

I don't think that the firmware will fix the communications problem, but you could try and see.

I went out and bought a USB-C SD card reader and updated the firmware that way...also bought a direct USB-C to USB-A port and it worked! Apparently hubs are detrimental to Canon Camera computer use. 

Anonymous
Not applicable

Good to hear of your success. I'll have to remember that concerning using a USB hub.

Avatar
click here to view the press release
Announcements