Canon Community Canon Community
 


Reply
BJB
Occasional Contributor
Posts: 10
Registered: ‎07-04-2015

MX922 takes forever for Android tablet to find and become active-other brand immediate

This is an ongoing issue with my top of the line AIO MX922.  We use android tablets in the house with the Canon android printer plug in.

 

When printing from email or Chrome Web browser it uses the plugin, not the Pixma standalone app.

 

My issue is this....when I choose "print", my non-canon laser becomes active (not grayed out) immediately.  Next, another family members bottom of the line canon will eventually show up. But my Mx922 will stay grayed out for quite a while longer.  It  has a static IP and I know it is "there".  Is there some kind of setting on the printer that would help? There are no settings in the plug in.  Once it wakes up and becomes active you can choose color, etc....but that's it.

 

Any ideas welcome. Since 90% of printing from android now, this might make me change brands if not fixable.  

 

Please don't give me the support number.  The windows driver for the MX922 defaults  to monochrome in the Edge browser, I called, spent time, sent info, and that is still not fixed....

 

Thanks,

BJB

Product Expert
Posts: 1,919
Registered: ‎10-17-2012

Re: MX922 takes forever for Android tablet to find and become active-other brand immediate

Hi BJB,

 

Disabling the Wireless LAN DRX and IPv6 settings on the printer may help with the issue being experienced. To do this, please follow these steps from the operation panel of the printer:

 

 1. Press the MENU button.

 

 2. Select SETUP, then press the OK button.

 

 3. Select DEVICE SETTINGS, then press the OK button.

 

 4. Use the arrow buttons to select LAN SETTINGS, then press the OK button.

 

 5. Use the arrow buttons to select OTHER SETTINGS, then press the OK button

 

 6. Use the arrow buttons to select WIRELESS LAN DRX SETTING, then press the OK button.

 

 7. Use the arrow buttons to select DISABLE, then press the OK This will return you to Other Settings menu.

 

 8. Use the arrow buttons to select TCP/IP SETTINGS, then press the OK button.

 

 9. Use the arrow buttons to select IPv6, then press the OK button.

 

10. Use the arrow buttons to select YES at confirmation screen [LAN communication may be disabled depending on your environment. Set this setting?] then press the OK button.

 

11. Use the arrow buttons to select ENABLE/DISABLE IPv6, then press the OK button.

 

12. Use the arrow buttons to select DISABLE, then press the OK button. This will return you to IPv6 settings menu where you can press MENU to exit to the main menu.

 

Please also ensure that your printer is as close as possible to your wireless router, and that there are not sources of interference (i.e., microwave ovens, cordless phones, baby monitors, bluetooth devices, etc.) between the two devices to ensure optimum wireless communication.

 

Should you still experience difficulty, we ask that you please contact a Canon technical support representative here for further assistance. A representative will be happy to assist you free of charge.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
BJB
Occasional Contributor
Posts: 10
Registered: ‎07-04-2015

Re: MX922 takes forever for Android tablet to find and become active-other brand immediate

Thanks for the suggestion.  My MX922 is right next to a Brother wireless printer with good connection.

 

These changes may have helped speed things up a little bit but the Canon is still quite a bit slower to become avaliable on my android devices to print than the other printers.

 

Thanks,

BJB

 

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement