Canon Community Canon Community
 


Reply
New Contributor
Posts: 2
Registered: ‎01-10-2018

MX472 no longer has IP settings?

When I first got the MX472, I was able to assign it an IP number. Then some years later, the only way it lets me connect to the wireless home network is via the WPS button, which I can manage by triggering it on the router side via the web gui and once it starts pinging, the printer very quickly finds it and says CONNECTED [OK].

Now my wireless computer doesn't see it even after uninstalling all the drivers, reinstalling the set up file I downloaded (the original disk is ruined). The only way my Windows 10 home sees it is when I add printer, THEN click on "The printer I want is not listed" -->Add a local or network printer with manual settings 

At this point, if I try "Create a new port" and try the default setting of Canon BJNP Port, I get 'Canon BJNP Port' cannot be added from the printer properties. If you use the printer on the network and have trouble with printing, install the printer driver again. Rinse, wash, repeat as the setup program is VERY limited and I cannot access the TCP/IP settings on the printer for some odd reason.

If I "Use an existing port" and select the non-fax Canon BJNP Port, then  select Canon, Canon MX470 series Printer, NEXT, it seems to install, but fails when I tell it to do a test page, citing printer error. What the hell do I do now?!

New Contributor
Posts: 2
Registered: ‎01-10-2018

Re: MX472 no longer has IP settings?

[ Edited ]

Either something failed on the printer or there was a firmware fix that has ruined it.
Watching a video on how to set up the Canon 400 series, I watched as the printer's LCD window spat out local SSIDs. I have TWO routers in the same room as the printer now, one 10' and the other 15' away and its not seeing any of those or the surrounding15 SSIDs in my apartment complex which my desktop has no trouble listing. I recall that as well and also have no access to it. It IMMEDIATELY jumps to WPS mode. EVERY. SINGLE. TIME. No matter where you try to access wireless settings.

Moderator
Posts: 510
Registered: ‎11-20-2012

Re: MX472 no longer has IP settings?

Hi Magnus005! 

 

Thanks for joining and posting in the Canon Forums! 

The Forum is not intended for immediate help, but a place to allow for the Community to give you assistance and feedback.

If you are in the United States and this is an urgent support need, please CLICK HERE to reach our friendly Technical Support Team. 

If you live outside the United States, please click here and select your country or region for your support needs.

We hope this helps! 

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement