Canon Community Canon Community
 


Reply
Occasional Contributor
Posts: 6
Registered: ‎03-14-2016

Re: DHCP not getting IP address from the wireless router

Well, I wasn't married to it and I have moved countries since ... Smiley Happy
Occasional Contributor
Posts: 5
Registered: ‎01-28-2017

Re: DHCP not getting IP address from the wireless router

Hehe... ;-) Well, thanks anyway for replying.

I'll try to fiddle around a bit more before abandoning it. I just purchased it, and returned it for a replacement. Same problem with the second one...
New Contributor
Posts: 1
Registered: ‎02-27-2017

Re: DHCP not getting IP address from the wireless router

I had the same problem. It turns out that either turning off "N" on the router - so it's just "BG" and turning off IPV6 on the printer did the trick. I have yet to work out if it was one or the other but that's what the nice person at canon support helped me to do.

Occasional Contributor
Posts: 5
Registered: ‎01-28-2017

Re: DHCP not getting IP address from the wireless router

I just tried switching off "n" on the router, but alas it didn't do any good.

As the printer doesn't have any display, I don't know how to turn off IPv6 there. All config is done through holding button in and waiting for x flashes of power LED and then releasing the button. So far, I haven'n found any such option for switching IPv6 on/off.

 

Thank you anyway. Smiley Happy

Moderator
Posts: 861
Registered: ‎10-25-2012

Re: DHCP not getting IP address from the wireless router

[ Edited ]

Hi MortenM,

 

Thanks for reaching out to Canon USA!

 

The PIXMA iP8750 is a Canon Europe exclusive model, which means that Canon USA doesn't support this printer. You'll want to check out the Wireless Connection Setup page located on the Canon Europe page HERE

 

If you're unable to get your printer connected using that tutorial, you'll want to contact Canon Europe for assistance. Their contact information can be found on the page located HERE

We hope this helps!

Highlighted
Occasional Contributor
Posts: 5
Registered: ‎01-28-2017

Re: DHCP not getting IP address from the wireless router

Thank you!

 

I understand this is a European model, and I have been in contact with Canon Support over here, but they failed to help me.

So I've been searching The Net for other (similar) models with similar problems. This US forum is the only place I've found something that resembles my problem.

 

I've tried the Wireless Connection Setup page you linked to, many times, and all the different options there - but still no luck.

No one has been able to solve my problem so far, neither in the US nor in Europe.

 

I am just about ready to give up on this printer and return it for a full refund. I think it is a shame no-one in Canon Support Europe has been able to fix my problem, and I think may just as well try another brand.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement