Canon Community Canon Community
 


Reply
Reputable Contributor
Posts: 884
Registered: ‎02-06-2013

Re: HELP - 580ex ii is FIRING when it's been disabled? (in master)

[ Edited ]

kmgsakoian wrote:

I tried disabling the flash on the flash unit, as well as on the camera, and it continues to flash. I did notice that the flash was going off right before, not affecting the shot, so maybe as a pre-flash? But I still don't want it to go off at all. Those settings you mentioned are what I have set on both of them. I tried clearing the settings on the camera as well, and then put them back to those settings, and it's still going off when it's disabled.

 

I'm confused - I don't think the 430exii is able to be used as a master?


If you see it's going off, it's probably for the purpose of focusing (but normally it's done by infrared, unless you disable the infrared function -not sure you can with the 5DIII - I don't have the camera with me to check)

 

I'm sorry you're right, the  430exII is not capable of being a master.  It's been a while since I last used the 580EX II and 430EX II and when I used them, I used a ST-E2-RT as the controller so the 430EX II I used was always a slave...I've switched over to using the radio control 600 series.

 

I guess I owe kvbarkley an apology also.  Since I use the St-E2-RT as the master and it does not use a flash, I'm a bit confused on why it would work differently on the 580EXII as a master.

================================================
Diverhank's photos on Flickr
Esteemed Contributor
Posts: 2,012
Registered: ‎02-17-2016

Re: HELP - 580ex ii is FIRING when it's been disabled? (in master)

It doesn't. It just has a red filter over the flash tube.

 

Follow my advice and get The Speedliter's handbook, you will learn more than you want to about stuff you will never own. 8^)

Esteemed Contributor
Posts: 3,794
Registered: ‎06-25-2014

Re: HELP - 580ex ii is FIRING when it's been disabled? (in master)


diverhank wrote:

kmgsakoian wrote:

I tried disabling the flash on the flash unit, as well as on the camera, and it continues to flash. I did notice that the flash was going off right before, not affecting the shot, so maybe as a pre-flash? But I still don't want it to go off at all. Those settings you mentioned are what I have set on both of them. I tried clearing the settings on the camera as well, and then put them back to those settings, and it's still going off when it's disabled.

 

I'm confused - I don't think the 430exii is able to be used as a master?


If you see it's going off, it's probably for the purpose of focusing (but normally it's done by infrared, unless you disable the infrared function -not sure you can with the 5DIII - I don't have the camera with me to check)

 

I'm sorry you're right, the  430exII is not capable of being a master.  It's been a while since I last used the 580EX II and 430EX II and when I used them, I used a ST-E2-RT as the controller so the 430EX II I used was always a slave...I've switched over to using the radio control 600 series.

 

I guess I owe kvbarkley an apology also.  Since I use the St-E2-RT as the master and it does not use a flash, I'm a bit confused on why it would work differently on the 580EXII as a master.


The AF assist beam is IR by default, but the remote control beam to the slave pretty clearly isn't. I don't have a 580EX ii manual handy, but I do have a 580EX manual. It makes no mention of using IR to fire the slave.

Bob
Boston, Massachusetts USA
Esteemed Contributor
Posts: 3,127
Registered: ‎06-11-2013

Re: HELP - 580ex ii is FIRING when it's been disabled? (in master)

You might want to pick up a copy of the "Speedliter's Handbook" by Syl Arena.  

 

Syl is a Canon "Explorer of Light" photographer and occasional does seminars on flash photography with Canon speedlites.

 

He does a great job explaining how the system really works and you finally understand how to control the speedlites. 

 

BTW, you can also just search for his name on YouTube... he has made a LOT of video tutorials and recorded seminars that you can watch.

 

As for the 430 not firing...

 

The master flash is communicating via the white strobe (which is why you see it flash even when disabled.  It only fires when the shutter is still closed and when the shutter opens only the remote flash should fire if the on-camera flash is set to 'disabled').  However... the receiver sensor is in the lower unit of both flashes and this needs a line-of-site to the flash on the on-camera master.  

 

If you are shooting indoors, the receiver may pick up the light reflection off the walls and ceilings and flash anyway.  But if you are outdoors, there's no walls to bounce the light so the off-camera flash typically wont fire unless you rotate the speedlite body so that the lower unit (the red lens) is pointed at the on-camera master.  The 'heads' swivel so you can still rotate the head to fire the light in whatever direction you need.

 

 

Tim Campbell
5D III, 5D IV, 60Da
Occasional Contributor
Posts: 5
Registered: ‎02-08-2017

Re: HELP - 580ex ii is FIRING when it's been disabled? (in master)

[ Edited ]

Thanks so much kvbarkley, & everyone else that's helped! I actually just bought the book hah. That makes sense then, because it's working now with the slave, and I've noticed the flash is not affecting the image when it's disabled, so it must be the pre-flash. 

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement