Canon Community Canon Community
 


Reply
Occasional Contributor
Posts: 5
Registered: ‎02-08-2017

HELP - 580ex ii is FIRING when it's been disabled? (in master)

Hey guys! So I have a 580exii that was working great as a master to my 430exii slave, up until last night. I was using it for a product set up, where I used the 430exii with my rapid box off to the left, and kept the flash off on the master. Now my 580exii keeps firing even though it's disabled, and it looks like it's no longer connected with the 430exii because it's no longer firing. What could have caused this? Does this sound like I need to get it fixed, or maybe a new one?

 

Thanks!

Respected Contributor
Posts: 1,776
Registered: ‎02-17-2016

Re: HELP - 580ex ii is FIRING when it's been disabled? (in master)

I think we need more data. You do know that the 580 will fire in E-TTL wireless mode to talk to the 430EX, right?

 

What camera? Are the settings in the camera correct?

Occasional Contributor
Posts: 5
Registered: ‎02-08-2017

Re: HELP - 580ex ii is FIRING when it's been disabled? (in master)

[ Edited ]

I did not know that! You'll have to excuse me, I'm a newbie in OCF. I disable it all the time and it's never gone off, so this is a first for me. It is in ETTL as of now, so that might explain it. But the slave still isn't firing. It's on the Canon 5D Mark iii, and the settings are 1/125, 7.1, ISO 100.

Reputable Contributor
Posts: 799
Registered: ‎02-06-2013

Re: HELP - 580ex ii is FIRING when it's been disabled? (in master)

There are reasons the flashes are doing what they're doing. Apparently something has changed.

Since the Master started to fire when it wasn't told to... Let's start there.

 

How was it told not to fire? At the flash or at the camera? Start at the camera first. Because the camera settings will override the flash settings. If the camera settings are correct then check the Master flash settings. The settings should be master, not firing, channel, ID. Then check the slave - slave, same channel and ID.

 

Kvbarkley was probably thinking of the built-in flash firing. The 580 will not fire visible flashes when told not to. By the way, the 430 is fully capable of being the Master use it. Use the 580 as the firing slave. It's more powerful and has more precise ETTL

================================================
Diverhank's photos on Flickr
Respected Contributor
Posts: 1,776
Registered: ‎02-17-2016

Re: HELP - 580ex ii is FIRING when it's been disabled? (in master)

No I am not. Even as a master in wireless flash mode the 580EX will fire the flash to talk to the slave. This is not an RT!

I do recommend Syl Arena's Speedliters handbook. It will cover *everything* you need to know.

Occasional Contributor
Posts: 5
Registered: ‎02-08-2017

Re: HELP - 580ex ii is FIRING when it's been disabled? (in master)

I tried disabling the flash on the flash unit, as well as on the camera, and it continues to flash. I did notice that the flash was going off right before, not affecting the shot, so maybe as a pre-flash? But I still don't want it to go off at all. Those settings you mentioned are what I have set on both of them. I tried clearing the settings on the camera as well, and then put them back to those settings, and it's still going off when it's disabled.

 

I'm confused - I don't think the 430exii is able to be used as a master?

Occasional Contributor
Posts: 5
Registered: ‎02-08-2017

Re: HELP - 580ex ii is FIRING when it's been disabled? (in master)

[ Edited ]

kvbarkley - Great - I'll definitely check that out! Thanks! So you're saying it will always go off? Because in the past I'm pretty sure I've been able to set it so it doesn't go off...maybe I'm wrong and never noticed it going off?

Respected Contributor
Posts: 1,776
Registered: ‎02-17-2016

Re: HELP - 580ex ii is FIRING when it's been disabled? (in master)

If you are using the flash as a controller (and don't have an RT flash!) then it has to fire to control the slave.

Reputable Contributor
Posts: 799
Registered: ‎02-06-2013

Re: HELP - 580ex ii is FIRING when it's been disabled? (in master)

[ Edited ]

kvbarkley wrote:

If you are using the flash as a controller (and don't have an RT flash!) then it has to fire to control the slave.


Yes, but it's using the infrared stuff...you won't see the flashes like in the case of the built-in flash.  Think about the ST-E2-RT...how does it control the slaves without having a flash? Answer: infrared.

================================================
Diverhank's photos on Flickr
Respected Contributor
Posts: 1,776
Registered: ‎02-17-2016

Re: HELP - 580ex ii is FIRING when it's been disabled? (in master)

No, they use the flash, the inrared does not have enough power to work in the sunlight. The ST-ET uses a low power flash tube with a red filter to cut down the annoyance factor. From the 580EX manual (note the note):

 

flash.jpg

 

I really wish you guys would make sure about things before confusing the issue with false information.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement