Canon Community Canon Community
 


Reply
New Contributor
Posts: 3
Registered: ‎01-07-2015

320EX Battery Issue

Hi --

 

I have a Speedlite 320EX and am experience the same issue I have seen others discussing here with the 600 speedlight.

 

The problem is the unit doesn't turn on with batteries in it.

 

If I open the battery compartment and then hold it closed without sliding it forward then the flash works. However, as soon as I slide it a bit forward to close it the flash stops working.

 

I'm guessing there is an issue with the connection to the batteries but this behavior is very bizarre.

 

I took a bunch of photos with the flash earlier in the day and then later when I tried to take more the flash didn't work. I thought maybe I had killed the batteries so I put fresh ones in and the flash still did not work. After reading about the issues with the 600 I experimented with my 320 and was able to determine that it worked if I held the battery door but not otherwise.

 

Anyone have the same experience? Any idea how to fix it?

 

Thanks

 

Rich

 

Highlighted
New Contributor
Posts: 3
Registered: ‎06-25-2017

Re: 320EX Battery Issue

Maybe you could attach a piece of velcro to hold the door shut.  Or get ahold of Canon's customer service to see if they have come up with a fix or could offer a replacement.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement