Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎11-12-2017

MX922: could not print using either Wifi or USB (scanning works)

OS: Windows 7 x64

 

My system had been working with an existing MX922 using Wifi print/scan until couple weeks ago when I bought a new MX922. I connected the new MX922, tried to print a few pages and realized I would need to uninstall and reinstall the MP driver since I had to do this same process for other PCs in the house earlier. I opened up the print queue, cancelled the print job, uninstalled the MP driver, reinstalled the MP driver (lastest from Canon website) but now the printer does not work anymore using either Wifi or even USB cable, the scanner seems to work fine when I start a scan job from the PC.

 

I even tried turning off the printer, PC and the router, wait a few minutes and turned everything back on, no joy !

 

 

When I run the Canon Network Tool I get an error "There are ports that cannot be used with their current settings...", the network tool also displays

 

   Name          Status       Model                            Port name

No Driver        Found      Canon MX920 series     CNBJNP_mac address

 

 

I have installed the driver many times before on several PCs in the house and this is the first time this has happened, there's probably something different about this particular PC but I have no idea what and the PC used to work fine with the old MX922.

 

The following is the log when running the driver setup program:

 

===========================================
Setup Results
===========================================

Model :
    Canon MX920 series

  Network Setup of the Printer :
    Failed
    Name :
    
    Port Name :
    CNBJNP_00BBC1B6D610

  Network Setup of the Scanner :
    Completed
    Name :
    Canon MX920 series(00.BB.C1.B6.D6.10)

  Network Setup of the Fax :
    Failed
    Name :
    
    Port Name :
    CNBJNPFAX_00BBC1B6D610

Network Type :
    Infrastructure
SSID :
    MyRouter

===========================================

 

 

PLEASE HELP ! I have spent close to 8 hours troubleshooting this to no avail.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement