Canon Community Canon Community
 


Reply
Occasional Contributor
Posts: 6
Registered: ‎03-25-2017

SX60. Ticking noise

Hi

Suddenly today I notice a ticking noise when I extend or retract the zoom. Everything seems to be working fine. Should I worry? Is it likely to fail in the near future? Warranty has ended I believe.

Reputable Contributor
Posts: 892
Registered: ‎03-01-2014

Re: SX60. Ticking noise

Check your warranty status and if it is still under warranty start a service request immediatley. Hard to say what is going on and that could be just a passing "glitch" or an early sign of an intenal mechanical problem. There mighr be something that got inot the lens assembly too which you can try and gently tap out. Hard to predict what will happen eventually so your best bet while the problem is occuring is to send it in under warranty. If not under warranty you can wait and see and hope it goes away. Service on these cameras isn't cheap if you have to pay and in a lot of cases buying a refurbished one is cheaper plus depending on where you get it you can get an extended warranty too. I think it is somewhere in the neighborhood of $130 just to look and tell you what the problem(s) is plus shipping. If you need a new lens assembly installed and calibrated it will be very expensive. Wish I had a better answer maybe someone else will reply with a better option for you.

Occasional Contributor
Posts: 6
Registered: ‎03-25-2017

Re: SX60. Ticking noise

Thanks for your thoughts on that. So far all is well & have done a firework photo/video shoot this evening problem free. I guess it's a case of crossing my fingers in the hope that it doesn't worse or fails since warranty has expired.

Product Expert
Posts: 813
Registered: ‎10-16-2012

Re: SX60. Ticking noise

Hi DLA23,

 

Thanks for posting.

 

If you continue to hear a ticking noise when the lens is in motion, I recommend contacting our technical Support Department. For contact options, please use this link: http://Canon.us/ContactCF

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
Occasional Contributor
Posts: 6
Registered: ‎03-25-2017

Re: SX60. Ticking noise

Thanks. I have referred the problem to Canon Support UK

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement