Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎02-24-2017
Accepted Solution

Half screen not showing on the Canon PowerShot SX530 HS

I am using my canon for the first time. Yesterday, everything worked fine. Today, only half of my display screen is showing. I have charged the battery overnight. I removed the SD card and battery for 15 minutes. I have changed settings on the DISP. button with no change. I could not find any information online. Just wondering if anyone has found a fix for this problem?

Highlighted
Moderator
Posts: 835
Registered: ‎10-25-2012

Re: Half screen not showing on the Canon PowerShot SX530 HS

Hi Dakoda!

 

When you press the menu, does the menu show across the entire screen? If so, can you please try to reset the camera to its default settings? You can do that by going to the MENU, then going to the right to the TOOLS menu, then arrow UP one time. You should see "Reset All Settings To Default." Press "Func./Set." It will confirm that you want to reset the camera. Arrow over to select "OK" and press "Func./Set." 

Once you've done that, check to see if that rectifies the problem. If it doesn't, reach out to our US-based technical support team for more options. They're at 1-800-OK-CANON (800-652-2666) during the week from 10am to 10pm.

We hope this is helpful!  

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement