Canon Community Canon Community

New Contributor
Posts: 2
Registered: ‎10-29-2017
Accepted Solution

MF toolbox can't find scanner

My MF4450 scanner worked 3 days ago, but it stopped funtioning today after my windows 10 pro recent patch, I guess. MF toolbox 4.9 can't connect to the scanner, with error msg" a supported scanner is not installed". The most funny part is windows fax & scanner can scan via this scanner. I connected the scanner to my PC directly via USB. Any solution?





Product Expert
Posts: 273
Registered: ‎02-28-2017

Re: MF toolbox can't find scanner

Hi chris_2000


Let's perform the following steps to resolve the error:


1. Open the Windows Desktop.

2. Right click on the MF Toolbox icon and click Properties.


3. Click the Compatibility tab, then click "Change settings for all users". 

4. Put a check next to "Run this program as an administrator", then click Apply and OK.

5.  Attempt to scan from the MF Toolbox software.


If the issue continues, click HERE for additionally steps to do to resolve the issue.


If you continue to have difficulties, please contact our support group using the following link:

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
New Contributor
Posts: 2
Registered: ‎10-29-2017

Re: MF toolbox can't find scanner

Thanks, James, yes, it solved my problem.
New Contributor
Posts: 2
Registered: ‎08-21-2017

Re: MF toolbox can't find scanner

Fantastic! Thanks for your help. No idea why MF Toolbox should stop working after 2 years of no problems, but after wasting about 5 hours reinstalling drivers etc I came accross your post which solved the problem in seconds. 


Thank you!



New Contributor
Posts: 1
Registered: ‎01-13-2018

Re: MF toolbox can't find scanner

Please help: My mf toolbox 4.9 that I have used with my Canon imageclass 216n printer suddenly won't work. It's worked with Windows 10 but not now. I have uninstalled the software to no avail. I have installed the latest driver software for the computer, but that's not worked either. I have reinstalled the toolbox software, but no luck. The printer connected by USB does work.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement