Canon Community Canon Community
 


Reply
Frequent Contributor
Posts: 111
Registered: ‎01-20-2016

error message on canon 1d III on sigma 500mm F4.5

Hello guys I have been getting the following error on a second hand sigma 500mm F4.5 I recently got from adorama on ebay and the seller seems to think its the lens which is faulty. I check the contacts they seem clean but the contacts on the lens look different to the 150-600 C and 17-50 2.8 I have. Could some one who owns the sigma 500mm dg hsm  F4.5 post a picture of what your contacts look like so I can compare please. I would like to know if its the lens or the camera.

 

I am not convinced as I do want to keep the lens. The error I get is this err 01 communications between the camera and lens is faulty clean the lens contacts.

 

adorama say they have spoken to sigma and they seem to think its the lens which needs repaired what do you think?

 

The camera is the 1d III its a 10 frame per second body I have never seen this error before on the sigma 150-600 c or 70-200 mk1 lens. Does any one have any ideas ? I tried out the lens on a canon 7d and 600d and dont get the error.

 

What is happening is after say 20 fast shots the camera some times shows this error up not always it seems to show up randomly 

 

any thoughts guys I remember some one saying their was issues with the canon 1d mk3 ?

Frequent Contributor
Posts: 111
Registered: ‎01-20-2016

sigma lens help 500mm ex hsm dg

Hi guys if any one owns the above lens could you post a photo of what your lens contacts looks like I wish to compare yours with mine to see if mine has damage on it thanks.

Respected Contributor
Posts: 1,513
Registered: ‎02-17-2016

Re: sigma lens help 500mm ex hsm dg

Chances are it needs to go to Sigma for a firmware update. If the contacts are the same shape as the contacts in the camera you should be fine.

Esteemed Contributor
Posts: 3,027
Registered: ‎06-25-2014

Re: error message on canon 1d III on sigma 500mm F4.5


paulbrogden10 wrote:

Hello guys I have been getting the following error on a second hand sigma 500mm F4.5 I recently got from adorama on ebay and the seller seems to think its the lens which is faulty. I check the contacts they seem clean but the contacts on the lens look different to the 150-600 C and 17-50 2.8 I have. Could some one who owns the sigma 500mm dg hsm  F4.5 post a picture of what your contacts look like so I can compare please. I would like to know if its the lens or the camera.

 

I am not convinced as I do want to keep the lens. The error I get is this err 01 communications between the camera and lens is faulty clean the lens contacts.

 

adorama say they have spoken to sigma and they seem to think its the lens which needs repaired what do you think?

 

The camera is the 1d III its a 10 frame per second body I have never seen this error before on the sigma 150-600 c or 70-200 mk1 lens. Does any one have any ideas ? I tried out the lens on a canon 7d and 600d and dont get the error.

 

What is happening is after say 20 fast shots the camera some times shows this error up not always it seems to show up randomly 

 

any thoughts guys I remember some one saying their was issues with the canon 1d mk3 ?


If both Sigma and Adorama think it needs work, who in his right mind would contradict them? Either send it in for repair or return it and get your money back.

Bob
Boston, Massachusetts USA
Esteemed Contributor
Posts: 3,807
Registered: ‎11-13-2012

Re: error message on canon 1d III on sigma 500mm F4.5

https://www.dpreview.com/forums/thread/3277170

 

See the above thread.

John Hoffman
Conway, NH

1D X, Rebel T5i, Many lenses, Pixma PRO-100, MX472
Frequent Contributor
Posts: 111
Registered: ‎01-20-2016

Re: error message on canon 1d III on sigma 500mm F4.5

The one thing your not getting is the lens works fine on my 7d and 600d but has this error only on  the 1d III seems strange to me why the error does not happen on the newer bodies.

Frequent Contributor
Posts: 111
Registered: ‎01-20-2016

Re: sigma lens help 500mm ex hsm dg

if i am honest the contacts look not too great on the sigma lense but the rest of the lens looks a1 the contacts on the canon 1d III look good and I do not get the error on the sigma 150-600 c or canon 70-200 II

Esteemed Contributor
Posts: 4,191
Registered: ‎08-13-2015

Re: error message on canon 1d III on sigma 500mm F4.5


paulbrogden10 wrote:

The one thing your not getting is the lens works fine on my 7d and 600d but has this error only on  the 1d III seems strange to me why the error does not happen on the newer bodies.


The 1D3 has a different focusing system, one which can focus at f/8 whereas the other cameras cannot.  Send it back.  

----------------------------------------------------------------------------------------------------------------------------------------------------------

"I don't rent software. I use Photoshop CS6, ACR 9.8 and Lightroom 6.8 ."
Frequent Contributor
Posts: 111
Registered: ‎01-20-2016

Re: sigma lens help 500mm ex hsm dg

IMG_1015.jpg 

 

Here is an example of what the 150-600 c contacts look like above . below is the sigma contacts for the 500mm F4.5 dg hsm prime lens. let me know if what you see has issuesIMG_1028.jpg

Frequent Contributor
Posts: 111
Registered: ‎01-20-2016

Re: sigma lens help 500mm ex hsm dg

IMG_1035.jpg

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement