Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎12-28-2015

Re: Autofocus not working. (18-55mm lens)

Hi Crystal,

  I have been having the same problem with my 18-55mm lens.  I am not sure if I am pulling the focus ring how I should.  Can you offer any further advice?

  Thank you

New Contributor
Posts: 1
Registered: ‎02-18-2016

Re: Autofocus not working. (18-55mm lens)

Thank you SO MUCH - worked like a charm - and to think I was about to give up and toss it!

New Contributor
Posts: 1
Registered: ‎04-02-2016

Re: Autofocus not working. (18-55mm lens)

Thank you!!! Followed the steps above and my lens is back to normal!!! ((Virtual hug))
New Contributor
Posts: 1
Registered: ‎04-17-2016

Re: Autofocus not working. (18-55mm lens)

I can't believe your tip actually worked!!! I am estatic!  Thank you so much.

New Contributor
Posts: 1
Registered: ‎04-18-2016

Re: Autofocus not working. (18-55mm lens)

[ Edited ]

Ohh, thank you all so much, this last little trick worked for me. This lens is only 3 years old and has never been abused. But I tried the GENTLE tug on the focus ring and heard the tiniest little click, re-attached it to the camera and VIOLA IT IS NOW WORKING!!!

New Contributor
Posts: 1
Registered: ‎04-26-2016

Re: Autofocus not working. (18-55mm lens)

Thanks for your tips on restoring the autofocus on the 18-50mm kit lens. it now works fine.

It has saved me buying a new lens.

Thanks again from the UK!

New Contributor
Posts: 1
Registered: ‎05-20-2016

Re: Autofocus not working. (18-55mm lens)

Hi,

 

Has anyone experienced this issue but only focussing one way? My lens will focus on a subject further away but refuses to focus back to nearer subjects. Its such a pain having to set to manual in order to reset the focus to near everytime!

New Contributor
Posts: 1
Registered: ‎06-05-2016

Re: Autofocus not working. (18-55mm lens)

Crystal! It worked! Here I've allways prided myself as being a hi tech cowboy. Of course i tried everything before going to the net. & of all things...all i had to do is pop a top! haha! TKU ! TKU ! TKU! I owe u a squeeze...i mean a hug..lol

New Contributor
Posts: 1
Registered: ‎06-07-2016

Re: Autofocus not working. (18-55mm lens)

You are genius!! I registered as a user here just to thank you for your advice. I had a similar issue with AF not working. It worked with my zoom lens, but not my 55mm lense. I looked up the issue online and finally came across your suggestion of the chiropractic tecnique. It did snap when I turned it and now it works perfectly! Thank you very much for your help!!! You rock!

New Contributor
Posts: 1
Registered: ‎06-12-2016

Re: Autofocus not working. (18-55mm lens)

Crystal:

Thank you for your brilliant suggestion, my autofocus is now working again!  I had tried the suggestions from Julius but no success, so I had nothing to lose by trying the gentle pulling on the focus ring and it worked - totally made my day!

I also took note of the comments saying that the main reason the problem occurs in the first place is the user is focussing manually when the AF is engaged - I'm sure I've been guilty of this in the past, without even thinking about it, so I will be more careful to avoid doing that in the future!

I also appreciate the comment stating that it's a good idea to put the lens in the MF mode when it's not in use, I will add that suggestion to my repertoire...

 

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement