Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎04-10-2015

Autofocus not working. (18-55mm lens)

Hello,

 

The autofocus on my Canon 18-55mm is malfunctioning and I'm afraid it may be broken.

All the internet research I've done points to issues electronic, but I believe this to be mechanical simply because of the noise it makes. With the lens set to AF, it does nothing, but makes a slight whirring sounds as if the camera is trying to, but can't focus the lens. In MF, turning the focus ring makes soft clicking sounds.

The autofocus works fine on the other lens I have.

The lens has not been dropped. I take really, REALY good care of my stuff!  Any other recommendations or bits of advice are much appreciated!

Reputable Contributor
Posts: 705
Registered: ‎06-11-2013

Re: Autofocus not working. (18-55mm lens)

Sorry, but it sounds as if the AF is broken or worn out. The "clicking noises" do suggest a mechanical failure. But to be sure, if possible, try the lens on a different camera to see if it works properly. Also, carefully clean the lens-to-camera contacts on the rear of the lens. Just use a clean, lint free rag lightly dampened with a couple drops of isopropyl (rubbing) alcohol. Also operate the AF on/off switch a dozen times or so... those switches are usually "self cleaning". If for any reason they get some oxidization or dirt inside, operatiing them will clean them.

 

To be honest, I don't have much hope that any of the above will "fix" the lens, because the noises suggest it's trying to AF, but failing. But it's easy and doesn't cost anything to try any of the above. 

 

If none of the above helps, you can look into repair, but unless it's still under warranty it might be more cost effective to simply replace with a new lens. Depending upon which version of 18-55mm yours is, a newer one or some other lens alternatives might be a nice upgrade anyway.

 

But first, a common reason the AF system gets damaged is manually overriding the auto focus of a micro motor lens without first turning the AF off at the switch. Canon warns not to do that with their micro motor lenses. On the other hand, their STM (stepper motor) and USM (ultrasonic) lenses both will tolerate manual override of AF without need to first turn it off. So, if yours is the micro motor version (i.e., it doesn't say STM on the lens... there is no USM version 18-55) and you weren't careful about turning off AF before focusing manually, this might have been the cause of the problem.

 

Currently there are two versions of that lens offered: EF-S 18-55 IS II sells for about $200 and EF-S IS STM costs about $50 more. You'll have to compare the cost of repairing the one you have, with these prices. But I also believe both current 18-55s are optically improved from the earlier version. In addition, the STM has improved AF performance (faster, smoother, quieter), a non-rotating front barrel (preferable if using filters such as polarizers), and tolerates manual focus override.

 

Or, if your budget allows, you maywant to consider a further upgrade such as the EF-S 18-135mm IS (also avail. with STM for about $50 more), EF-S 15-85mm IS USM, or EF-S 17-55/2.8 IS USM.

 

***********
Alan Myers

San Jose, Calif., USA
"Walk softly and carry a big lens."
GEAR: 5DII, 7D(x2), 50D(x3), some other cameras, various lenses & accessories
FLICKR & PRINTROOM 

Product Expert
Posts: 256
Registered: ‎12-07-2012

Re: Autofocus not working. (18-55mm lens)

Hi marcosochoa!

 

amphoto1 makes some very valid points, and it does sound like it could  be the motor in the lens. We have found that sometimes we're able to remedy this without a costly repair, but it is a multi-stepped process.

 

Try this:

  1. Take the lens off of your camera.
  2. Put the lens in MF mode.
  3. Twist the FOCUS ring (the tip of the lens) all the way to one side (extend it). You may hear a click noise or two, this is good, but don't FORCE the lens.
  4. Twist the FOCUS ring all the way to the opposite side (retract it). Again, you may hear a couple of clicking noises. What we hope is happening is the focusing motor being put back into its proper place.
  5. Put the lens back on the camera.
  6. Put the lens in AF mode.
  7. Turn the camera on.
  8. Put the camera in AUTO or P mode.
  9. Take a test photo.
  10. Profit.

Hopefully this solves your problems, and you never have to worry about it again! With my personal lenses that are not USM or STM, I always store and transport them with the AF/MF switch in the MF position. This disengages the focusing motor and prevents any accidental damage to the auto focusing motor.

 

If this didn't solve your problem, please feel free to click HERE to contact us for additional troubleshooting, and explore other options that might be available to you.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
New Contributor
Posts: 1
Registered: ‎10-08-2015

Re: Autofocus not working. (18-55mm lens)

Thanks Julius! You saved me a couple hundred bucks!
New Contributor
Posts: 1
Registered: ‎11-21-2015

Re: Autofocus not working. (18-55mm lens)

Hi Julius, I'm experiencing marcosochoa's exact issues except my lens doesn't make any clicking noises. When it's on AF it does sound like it's trying to focus but it doesn't manage to. I've tried your suggestion without any luck. Do you have any other advice?

 

Thanks in advance!

Frequent Contributor
Posts: 57
Registered: ‎10-20-2015

Re: Autofocus not working. (18-55mm lens)

I had a Quantaray lens that started doing that. I took it in to a repair shop and it was an older one. They said they couldn't get the part to fix it and I'd have to send it to Japan. I called Quantaray, but they wanted a ridiculous amount of money, even with the trade back, so I just found a newer lens.
It started out as a random thing and then got to where it wouldn't work at all.
New Contributor
Posts: 2
Registered: ‎12-15-2015

Re: Autofocus not working. (18-55mm lens)

Hi....I had the same problem with my AF lens not working. I found on another forum someone who suggested to do this:
"Pulling gently on the focus ring worked for us. Slight pop, maybe 1/16" movement, and the lens is working again!"

I tried it and INSTANTLY my lens is working. I continued reading just a few more comments to see if others related to it and there were SEVERAL people who stated that it worked for them also. I AM THRILLED that I won't have to purchase a replacement lens. DEFINITELY TRY IT. I twisted it (slightly hard because what did I have to loose at that point) and it gave a loud pop but it did the trick!!!
Esteemed Contributor
Posts: 3,615
Registered: ‎06-25-2014

Re: Autofocus not working. (18-55mm lens)


crystal wrote:
Hi....I had the same problem with my AF lens not working. I found on another forum someone who suggested to do this:
"Pulling gently on the focus ring worked for us. Slight pop, maybe 1/16" movement, and the lens is working again!"

I tried it and INSTANTLY my lens is working. I continued reading just a few more comments to see if others related to it and there were SEVERAL people who stated that it worked for them also. I AM THRILLED that I won't have to purchase a replacement lens. DEFINITELY TRY IT. I twisted it (slightly hard because what did I have to loose at that point) and it gave a loud pop but it did the trick!!!

I think I'm glad I don't own that lens.

Bob
Boston, Massachusetts USA
New Contributor
Posts: 2
Registered: ‎12-15-2015

Re: Autofocus not working. (18-55mm lens)

LOL!!!

Frequent Contributor
Posts: 57
Registered: ‎10-20-2015

Re: Autofocus not working. (18-55mm lens)

I do believe if an authorized repair center could not fix it, that would not be an option either.
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement