Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎03-02-2017

Re: Autofocus not working. (18-55mm lens)

Hi have just tried the remedy for the AF not working on the 18-55mm lens, it works! Many thanks indeed.

New Contributor
Posts: 1
Registered: ‎03-31-2017

Re: Autofocus not working. (18-55mm lens)

Tried pulling on the lens ring with it in MF mode..still won't focus!

Esteemed Contributor
Posts: 4,709
Registered: ‎08-13-2015

Re: Autofocus not working. (18-55mm lens)


johnnybongo wrote:

Tried pulling on the lens ring with it in MF mode..still won't focus!


Instead of "pulling" on the lens, which can only damage it, try rotating the focus ring.  Read the post by Canon Product Expert Julius on the first page.  

 

I also suggest that you read all of the posts, because others had one trouble or another, but found a way to overcome them and described what they did.  In most cases, people just had to have a little courage and TURN the focus ring a little bit harder.  

 

NOTE:  Canon has made a few different versions of the 18-55mm lens.  This fix is not intended for lenses with model numbers that end with "STM".  If your "STM" lens seems stuck, then you need to contact Canon U.S. Support at 1-800-OK-CANON.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"I don't rent software. I use Photoshop CS6, ACR 9.8 and Lightroom 6.8 ."
Highlighted
New Contributor
Posts: 1
Registered: ‎04-21-2017

Re: Autofocus not working. (18-55mm lens)

Hmmm, my AF was working some of the time - untli I tried this. Now it doens't work at all. Any suggestions to undo whatever went wrong?  No clunks or pops durign the steps. I did extend and retract the zoom - I always have had issues figuring out which ring the focus one is.

New Contributor
Posts: 1
Registered: ‎06-01-2017

Re: Autofocus not working. (18-55mm lens)

Hello,

I've had my Canon Rebel t3i about 3 1/2 years now.  I do a lot of traveling abroad.  I use the autofocus a lot with both of my lenses.  This last trip the autofocus would work intermittently with both lenses then all of a sudden not work.  When it did work I could hear it try to focus and see the difference.  When it didn't work it didn't do anything.   No noise or anything.  It did it off and on with both lenses so I don't think the lenses are the problem.  Does anyone have any idea what might be going on?

Esteemed Contributor
Posts: 3,336
Registered: ‎06-25-2014

Re: Autofocus not working. (18-55mm lens)


heathershaven wrote:

Hello,

I've had my Canon Rebel t3i about 3 1/2 years now.  I do a lot of traveling abroad.  I use the autofocus a lot with both of my lenses.  This last trip the autofocus would work intermittently with both lenses then all of a sudden not work.  When it did work I could hear it try to focus and see the difference.  When it didn't work it didn't do anything.   No noise or anything.  It did it off and on with both lenses so I don't think the lenses are the problem.  Does anyone have any idea what might be going on?


The usual explanation is that somebody had tried to manually focus the lens while it was in autofocus mode. Many Canon lenses are OK with that action, but on most or all versions of the 18-55 it tends to jam the autofocus mechanism. Sometimes the lens can be unjammed without significant damage by manhandling it in a prescribed manner (recorded in detail at least once in this forum) and sometimes not. If it doesn't work, your only recourse is to try to have it fixed; but many people think that paying to have such a cheap lens fixed is a waste of money.

Bob
Boston, Massachusetts USA
New Contributor
Posts: 1
Registered: ‎06-18-2017

Re: Autofocus not working. (18-55mm lens)

I just want to say thank you sooooooo much for the tip on pulling out the focusing ring.  It worked for me to!!!!!

New Contributor
Posts: 1
Registered: ‎07-04-2017

Re: Autofocus not working. (18-55mm lens)

I fixed it! Thanks!

Occasional Contributor
Posts: 5
Registered: ‎07-03-2017

Re: Autofocus not working. (18-55mm lens)

[ Edited ]

I have a t2i, the 18-55mm autofocus wont work, but if I put my 100-400L lens on t2i, the autofcus works. I can put the 18-55 on my t7i and the autofocus works fine. Is this maybe a problem with one of my contact pins on the t2i. Any ideas on which pin it would be?

 

Also, could this be a focus screen problem - I've went through several with the t2i - almost a million on shutter count

 

Esteemed Contributor
Posts: 4,709
Registered: ‎08-13-2015

Re: Autofocus not working. (18-55mm lens)

Whatever the exact issue might be, it seems that your T2i is at the center of it.  Look for wear and tear on the surfaces of the contacts on the camera and the lens.  Do not touch the contacts with your fingers, as that can leave potentially harmful body oils behind.

 

The contacts in the camera should be slightly springy, so make none of them is stuck or has sticky action when depressed.

 


One way to test the AF with the lens is to put the camera on a tripod, and set it to One Shot mode, the mode that beeps.  Set the camera to manually select the center AF point, and switch the lens to MF mode.  

Manually focus the lens on something about 50x the focal length distance from the camera using Live View.  If memeory serves, that model has LIve View.  If not, do the best job that you can do through the viewfinder.

Once focused, take a couple of test shots to confirm the quality of your focus.  With the camera in One Shot mode, and the lens in MF mode, you should still get a focus confirmation beep when you take a picture.  

 

Try it with other lenses, to make sure that you can get a confirmation beep while the lens is still in MF mode.  If you lack a tripod, find a good spot on a backyard table, or another location with a low risk of being bumped and falling.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"I don't rent software. I use Photoshop CS6, ACR 9.8 and Lightroom 6.8 ."
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement