Canon Community Canon Community
 


Reply
New Contributor
Posts: 3
Registered: ‎04-23-2017

18-55mm STM (f/3.5-5.6) -- Broken circuit cables

So I dropped my kit lens and as I was turning the zoom ring I heard clacking.

I noticed while zooming toward 18mm that the back element was "loose."

 

I opened up the lens from the back and noticed that the back element was actually connected to other elements in a "group" of several pieces of glass.

 

Upon trying to resolve the issue, I took off the zoom grip and just tightened the screws, which fixed the problem.

 

However, while taking off the circuits from the back end, 2 circuits got severed.

 

[Picture below; see encircled]

IMG_7051.JPG

 

In using the lens, I've noticed the following:

(a) The camera does not recognize the correct zoom positions. From zooming 18-55mm, the camera recognizes this as something along the lines of 45mm at the 18mm position, 18mm anywhere after 24mm.

 

(b) The aperture settings are wrong. (Might be related to zoom settings.) It starts at f/4.5 at 18mm, and then anywhere after 24mm the highest is at f/3.5. When using the DOF preview at the 55mm position, if I set my aperture past f/5.6 nothing physically happens.

 

(c) The camera focuses fine from 18mm to 24mm with AF. Anywhere after and AF will just hunt through a very short range, shaking back and forth. MF is completely dysfunctional even with the switch at MF, and still seems to "hunt."

 

 

I was trying to see if I can find replacements online and only found replacements for a "focus aperture flex cable"?

1. Is this either of these cables?

2. What do these cables control?

 

Also, how would I open up the lens in order to fix this issue? I only found instructions online for older versions of this lens, but not the STM version.

 

I understand that the warranty no longer applies as I dropped it (still within 1 year of purchase) so either I spend money to send it in and fix it, or I fix it myself. I'm wondering if there are ways I can do so myself?

 

Thank you for your time!

 

Honored Contributor
Posts: 7,688
Registered: ‎12-07-2012

Re: 18-55mm STM (f/3.5-5.6) -- Broken circuit cables

[ Edited ]

IMHO, I would cut your loses and buy another lens.  This lens is not worth fixing, cost wise that is.  Two things, Canon won't warranty a dropped lens and certainly not one you took apart.  Lastly you don't know if there is further damage to the circuit boards and lens alignment.

A lot of Canon stuff. Along with, a lot of other stuff.
New Contributor
Posts: 3
Registered: ‎04-23-2017

Re: 18-55mm STM (f/3.5-5.6) -- Broken circuit cables

Hi, I was able to find replacement cables online; they weren't expensive, so I thought I might as well try fixing it myself. I was just wondering what these cables were called because I'm not exactly sure what they control.
Esteemed Contributor
Posts: 3,336
Registered: ‎06-25-2014

Re: 18-55mm STM (f/3.5-5.6) -- Broken circuit cables


rwu28 wrote:
Hi, I was able to find replacement cables online; they weren't expensive, so I thought I might as well try fixing it myself. I was just wondering what these cables were called because I'm not exactly sure what they control.

And you have just explained why you shouldn't be trying to fix it yourself.

Bob
Boston, Massachusetts USA
Highlighted
New Contributor
Posts: 3
Registered: ‎04-23-2017

Re: 18-55mm STM (f/3.5-5.6) -- Broken circuit cables

Of course. I haven't; that's why I came here to ask!
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement