Canon Community Canon Community
 


Reply
Frequent Contributor
Posts: 113
Registered: ‎09-29-2015

Re: My camera Canon 5D Classic or Mark I doesn't turn on. :(

No harm putting one back in. It's only a dollar or two. It stores the date/time and camera settings. If you have the BP511 out for sometime, the capacitor inside may have exhausted and the camera cannot get back to normal.

 

BTW, why you remove the button battery ?


alcesamuelpaul wrote:

It used to work... the Camera is working without the battery since december.  


 

Occasional Contributor
Posts: 7
Registered: ‎05-08-2017

Re: My camera Canon 5D Classic or Mark I doesn't turn on. :(

Good Question! when I brought the Camera the battery was not good. I buy a new batt. But the batt keep frozen the camera. but when i remove the batt the camera works properlly. Smiley Happy

 

anyway i am gonna try to put the one have in it once again.

Esteemed Contributor
Posts: 3,862
Registered: ‎11-13-2012

Re: My camera Canon 5D Classic or Mark I doesn't turn on. :(

If you are talking about the button battery causing a problem check that you are installing it correctly. Check the + orientation. 

John Hoffman
Conway, NH

1D X, Rebel T5i, Many lenses, Pixma PRO-100, MX472
Occasional Contributor
Posts: 7
Registered: ‎05-08-2017

Re: My camera Canon 5D Classic or Mark I doesn't turn on. :(

Hello GUYS!!!

                        You will never understand how happy i am because the camera start working again. 

It seems that it was really an issue related the flat back up batt. You where really helpful to me guys. Many thanks to all of you who have shared ideas about my Camera issue. 

 

Thanks once again.

 

 

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement