Canon Community Canon Community
 


Reply
Super Contributor
Posts: 172
Registered: ‎09-29-2015

Re: My camera Canon 5D Classic or Mark I doesn't turn on. :(

No harm putting one back in. It's only a dollar or two. It stores the date/time and camera settings. If you have the BP511 out for sometime, the capacitor inside may have exhausted and the camera cannot get back to normal.

 

BTW, why you remove the button battery ?


alcesamuelpaul wrote:

It used to work... the Camera is working without the battery since december.  


 

Occasional Contributor
Posts: 7
Registered: ‎05-08-2017

Re: My camera Canon 5D Classic or Mark I doesn't turn on. :(

Good Question! when I brought the Camera the battery was not good. I buy a new batt. But the batt keep frozen the camera. but when i remove the batt the camera works properlly. Smiley Happy

 

anyway i am gonna try to put the one have in it once again.

Esteemed Contributor
Posts: 4,365
Registered: ‎11-13-2012

Re: My camera Canon 5D Classic or Mark I doesn't turn on. :(

If you are talking about the button battery causing a problem check that you are installing it correctly. Check the + orientation. 

John Hoffman
Conway, NH

1D X, Rebel T5i, Many lenses, Pixma PRO-100, MX472
Highlighted
Occasional Contributor
Posts: 7
Registered: ‎05-08-2017

Re: My camera Canon 5D Classic or Mark I doesn't turn on. :(

Hello GUYS!!!

                        You will never understand how happy i am because the camera start working again. 

It seems that it was really an issue related the flat back up batt. You where really helpful to me guys. Many thanks to all of you who have shared ideas about my Camera issue. 

 

Thanks once again.

 

 

Occasional Contributor
Posts: 11
Registered: ‎11-30-2012

Re: My camera Canon 5D Classic or Mark I doesn't turn on. :(

Hi

 

My 5D classic has exactly the same problem. But i tried doing a hard reset, removed both batteries, left it on all night and still the same. Replaced also the backup battery, the problem persists.

 

Any more sugestions?

Occasional Contributor
Posts: 11
Registered: ‎11-30-2012

Re: My camera Canon 5D Classic or Mark I doesn't turn on. :(

[ Edited ]

This happened all of a sudden. I took a lot a photos, arrived at home removed the photos from card then put it back. On the next day i changed lens, turned it on and nothing. I thought it was the battery, so i charged it and then put it on the camera and then only the top lcd screen works and the buttons next to it. The LCD on the back doesn't turn on, nor the buttons on the back, it doesn't shoot. And the aperture doesn't appear on the top lcd screen, only the speed, even on M mode. When i turn on the camera, the red light light near the back wheel doesn't turn on like it was usual...

 

Could it be a loose cable or has the board fried?

Esteemed Contributor
Posts: 3,725
Registered: ‎06-25-2014

Re: My camera Canon 5D Classic or Mark I doesn't turn on. :(


Azathoth wrote:

This happened all of a sudden. I took a lot a photos, arrived at home removed the photos from card then put it back. On the next day i changed lens, turned it on and nothing. I thought it was the battery, so i charged it and then put it on the camera and then only the top lcd screen works and the buttons next to it. The LCD on the back doesn't turn on, nor the buttons on the back, it doesn't shoot. And the aperture doesn't appear on the top lcd screen, only the speed, even on M mode. When i turn on the camera, the red light light near the back wheel doesn't turn on like it was usual...

 

Could it be a loose cable or has the board fried?


You say that you charged the battery, but not that you changed it. If the battery is original from when you bought the camera, maybe it's now having trouble acquiring or holding a charge. I'd change it out and see.

 

Another possibility that's not ruled out by the facts is that the battery charger is defective.

Bob
Boston, Massachusetts USA
Super Contributor
Posts: 172
Registered: ‎09-29-2015

Re: My camera Canon 5D Classic or Mark I doesn't turn on. :(

Check the micro switches at the battery door and CF card door. If either of them gets stuck, the camera won't start.

 

If you don't understand, go to Youtube and check out the tutorials.

Super Contributor
Posts: 127
Registered: ‎02-13-2016

Re: My camera Canon 5D Classic or Mark I doesn't turn on. :(


alcesamuelpaul wrote:

...It seems that it was really an issue related the flat back up batt. You where really helpful to me guys. Many thanks to all of you who have shared ideas about my Camera issue. 

 

Thanks once again.

 

 


Also make sure that you reset the calendar and clock. I've seen it mentioned that if you don't there can be some issues with some camera operations.

Occasional Contributor
Posts: 11
Registered: ‎11-30-2012

Re: My camera Canon 5D Classic or Mark I doesn't turn on. :(

[ Edited ]

Yeah i checked the microswitches but the problems still persists.

 

What i have not tried yet is with a different battery. Not very easy to find someone with that battery model... 

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement