Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎10-06-2017

EF-M 11-22 possible motor issue, please advise.

Hello, 

 

I have an EOS M5, using it mainly with adapter and ef lenses, but kept the little 11-22 EF-M, because I was very happy with its result. Hadn't used it in a while. 

Upon screwing it into the camera, I get a brief buzz noise from the motor. The camera freezes for about 30 seconds, after which I get the usual view, but in MF mode, F/00. Obviously I can focus manually, but the shutter doesnt work either.

I'm guessing the motor is the problem. It is making a sound, so still something happening, not totally dead. Puting back another lens, they work fine.

 

Any ideas of the possible cause, and solution , before taking it to repair ?

One thing I noticed, I handn't locked the lens before putting it away, travelled with it a bit (never been hit, dropped or anything). Could something have broke there ?

 

Thank you in advance!

Highlighted
Honored Contributor
Posts: 5,228
Registered: ‎08-13-2015

Re: EF-M 11-22 possible motor issue, please advise.


dimiter wrote:

Hello, 

 

I have an EOS M5, using it mainly with adapter and ef lenses, but kept the little 11-22 EF-M, because I was very happy with its result. Hadn't used it in a while. 

Upon screwing it into the camera, I get a brief buzz noise from the motor. The camera freezes for about 30 seconds, after which I get the usual view, but in MF mode, F/00. Obviously I can focus manually, but the shutter doesnt work either.

I'm guessing the motor is the problem. It is making a sound, so still something happening, not totally dead. Puting back another lens, they work fine.

 

Any ideas of the possible cause, and solution , before taking it to repair ?

One thing I noticed, I handn't locked the lens before putting it away, travelled with it a bit (never been hit, dropped or anything). Could something have broke there ?

 

Thank you in advance!


You might want to go into the menus, and disable the option to retract lenses on power down when you use that lens.

Make sure that you power down the camera when you change lenses.  If you are reading F/00 on the aperture, than your lens is not communicating with the camera body.  If you can auto-focus with the adapter and EOS lenses, then the EF-M lens is most likely dead or dying.  Contact Canon Support for the best advice.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"I don't rent software. I use Photoshop CS6, ACR 9.8 and Lightroom 6.8 ."
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement