Canon Community Canon Community
 


Reply
Honored Contributor
Posts: 5,038
Registered: ‎08-13-2015

Re: Color Problem with 5D Mark 3

If you are shooting RAW, the WB setting becomes irrelevant while you are shooting.  But, if you are shooting JPEGs, then a manual setting of 7300(?) is not the value that you want in bright sunschine.  You would want something around 5300 to 5700.

If you have not used Canon's DPP post processing software, then I highly recommend that you start.  The application makes converting RAW images to JPEG a simple 2-3 click procedure.  Select a file, select the command, select a storage location.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"I don't rent software. I use Photoshop CS6, ACR 9.8 and Lightroom 6.8 ."
Esteemed Contributor
Posts: 2,994
Registered: ‎06-11-2013

Re: Color Problem with 5D Mark 3


Dusty87 wrote:

TCampbell wrote:

I noticed the color temperature and tint was changed between the two images (looking at your adjustment controls on the right).  

 

I wish I had non-adjusted original data.  Can you convert your CR2 files into a 16-bit tiff but give us straight-out-of-the-camera shots to compare?

 

I'm using my digital color meter on the images and checking the center of the subjects forhead as well as the cheek just to the right of the block spot.  

 

The blue-channel values seem to be similar.  The green channel is moderately boosted ... but the red channel is more significantly boosted.   

 

Something else... you're taking a photo that's LOADED with greenery everywhere.  The grass, the trees, etc.   Can you "see" the mostly green surroundings with your eyeball?  That's because green light is bouncing off those background elements and traveling toward you.  It's not just hitting your eyeball and your camera lens.. it's hitting your subject.  Your "light" will have a color cast based on the dominating colors in your surroundings.  This is why we use gray cards to calibrate the image.

 

 

When I toggle between the two images and just look at the histogram, I can see the histogram is spread more broadly on the 5D III (but then you didn't use the same background so that might explain it.  And possibly subtle variances in light level since the subject isn't in sunlight.)

 

You're not collecting good comparable data.  Ideally you'd photograph a gray card in identical light with identical background (and I do mean IDENTICAL... not merelely similar enough that most people wouldn't fuss over it) and taken at the same time in IDENTICAL light (again... if clouds are moving in and out and brightness is varying... you've invalidated the test.)

 

In order to isolate the difference between cameras, you have to make sure there are zero difference between the subject (not just very little difference... it most be none, zero, nada, zilch.)  

 

Otherwise you can fall into the trap of "selective data" (using examples that support your hypothesis and ignoring the examples that contradict your hypothesis.)  

 

 

 


I don't know why the temp & tint change themselves.. I had both of them set to 7300K, I believe, but it would appear I'm shooting at 2 different WB's. And I'm afraid that might be part of the problem.


I don't know how to convert a CR2 to a 16-bit TIFF, but I'm willing to try.


With your naked eye, you can't tell a difference between the two images? I purposely put him in a lot of greenery (although, I did not know he was going to wear a green shirt). But my point in that was... my Mark 2 would have easily responded to all of the green very well, and handled it like a champ. However, my Mark 3... that's just not happening.

I will say, though, the background is identical. We stayed in this little 10-ft area of the yard. It might just be zoomed in, or panned to the left, or what have you.

I'm on my way out the door to take some more test shots, both WITH a WB tool and without. (I have the ExpoDisc.)




I do notice the difference... one is a bit brighter.  The blue is similar, the green is slightly brigher on the 5D III and the red is even brigher still on the 5D III.  You can see that in the histogram.   I was using the "Digital Color Meter" app on my Mac and mousing over the pixels to read the RGB values.

 

Honestly... you can afford a 5D III... you can CERTAINLY afford a $10 grey card and learn to use it.  Problem solved.

 

You are spending far too much energy on this 'green' thing to not come away learning something from this experience (namely, how to use a gray card to fix all this).    This is going to cost you all of $10... and about 10 minutes of your time to learn to use it.    Once you know how to use a gray card... color is no longer an issue no matter how much or how little you pay for any camera.

 

Please, please, please... don't make me create yet another post suggesting you get a gray card.  Just get one already.  You'll thank me for harassing you until you get one.

 

Tim Campbell
5D III, 5D IV, 60Da
Honored Contributor
Posts: 5,038
Registered: ‎08-13-2015

Re: Color Problem with 5D Mark 3

The problem with a grey card is that i suspect that OP does not know how to use post processing software.  I think the OP wrote that they do not know how to convert RAW to JPEGs.  If you do not know how to do that, then you're either not using post processing software effectively, or at all.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"I don't rent software. I use Photoshop CS6, ACR 9.8 and Lightroom 6.8 ."
Occasional Contributor
Posts: 15
Registered: ‎08-28-2017

Re: Color Problem with 5D Mark 3

Wadizzle, answering on my mobile, so i can't quote you.. But I DO know how to convert RAW to JPEG. TCampbell was asking me to convert RAW files to TIFF files so they could see them. I was saying I don't know how to do that.

Yes. I'm not an idiot. I have to convert RAW files to JPEGs to deliver to my clients. I do that with Elements and it's a 3 click process, too.

TCampbell- I don't have a grey card. But I do have an ExpoDisc. That's the same thing basically, right? I just shot some test shots with it. But I won't be able to review/share those til later tonight.

Honored Contributor
Posts: 5,038
Registered: ‎08-13-2015

Re: Color Problem with 5D Mark 3


Dusty87 wrote:
Wadizzle, answering on my mobile, so i can't quote you.. But I DO know how to convert RAW to JPEG. TCampbell was asking me to convert RAW files to TIFF files so they could see them. I was saying I don't know how to do that.

Yes. I'm not an idiot. I have to convert RAW files to JPEGs to deliver to my clients. I do that with Elements and it's a 3 click process, too.

TCampbell- I don't have a grey card. But I do have an ExpoDisc. That's the same thing basically, right? I just shot some test shots with it. But I won't be able to review/share those til later tonight.


Great.  Converting to a TIFF should be as simple as selecting a different file type.  One more click.

I bought an ExpoDisc, but I am not sure if i like it.  I need something to put at the location of the subject, which captures the light falling on the subject.  My ExpoDisk captures light that is reflected towards the camera from all directions.  I think I still need a grey card.  Furthermore, I question the life expectancy of the ExpoDisc, how long will its' grey be an accurate grey.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"I don't rent software. I use Photoshop CS6, ACR 9.8 and Lightroom 6.8 ."
Occasional Contributor
Posts: 15
Registered: ‎08-28-2017

Re: Color Problem with 5D Mark 3

For those who were asking, here is a link to the test shots from today. I did a shot with each camera, using an ExpoDisc while shooting (stand where the subject is, cover lens with ED and point at shooting area, snap, set custom WB, go to shooting area, snap suject)... And just for kicks again, I set a custom WB of 8800 K while shooting, and took test shots with each. Using an ExpoDisc did nothing for the color issue.

Please note: pay no attention to the poor focus on the Mark 2 images. This was the reasoning I had for buying the Mark 3 to begin with. 

*I also included TIFF files...

https://www.dropbox.com/sh/9yo6zpu6u33ntd3/AADrzQwU7QCGG9r1GcC3yBq6a?dl=0

Honored Contributor
Posts: 5,038
Registered: ‎08-13-2015

Re: Color Problem with 5D Mark 3


Dusty87 wrote:

For those who were asking, here is a link to the test shots from today. I did a shot with each camera, using an ExpoDisc while shooting (stand where the subject is, cover lens with ED and point at shooting area, snap, set custom WB, go to shooting area, snap suject)... And just for kicks again, I set a custom WB of 8800 K while shooting, and took test shots with each. Using an ExpoDisc did nothing for the color issue.

Please note: pay no attention to the poor focus on the Mark 2 images. This was the reasoning I had for buying the Mark 3 to begin with. 

*I also included TIFF files...

https://www.dropbox.com/sh/9yo6zpu6u33ntd3/AADrzQwU7QCGG9r1GcC3yBq6a?dl=0


As I noted just above, the whole idea behind how an ExpoDisk is to be used is severely flawed. 

You want a sample of the light falling on the subject.  Placing the ExpoDisk over the lens samples the light falling on the camera.  Intuitively, the difference between the sampleing techniques may seem negligible.  But, your sample photos are nearly a textbook example of why you want to sample the light falling on the subject. 

 

It seems to be an overcast day, without bright sunshine, so the difference may not be as clear.  When you place the ED over the lens, most of the light reaching the ED on the front of the lens is what is reflected off of the wall behind the model. 

 

When your model holds a grey card, most of the light reaching the grey card is direct sunlight.  You are sampling one light source for WB, but shooting with another light source, which has a different color temperature.

BTW, where did the 8800K manual setting come from?

----------------------------------------------------------------------------------------------------------------------------------------------------------

"I don't rent software. I use Photoshop CS6, ACR 9.8 and Lightroom 6.8 ."
Occasional Contributor
Posts: 15
Registered: ‎08-28-2017

Re: Color Problem with 5D Mark 3

Weather was a little cloudy.. But mostly sunshine. We were just tucked behind an old building.

Even with all those factors, the differences in color are super obvious to me.

The 8800K came from just observation/ trial & error while shooting. I've always done that with WB when it comes to shooting. But apparently, I'm going to have to change my method, since there doesn't seem to be a rhyme or reason behind the difference in color between the 2 and 3, and there doesn't seem to be a simple in-camera fix for it.
Honored Contributor
Posts: 5,038
Registered: ‎08-13-2015

Re: Color Problem with 5D Mark 3


Dusty87 wrote:
Weather was a little cloudy.. But mostly sunshine. We were just tucked behind an old building.

Even with all those factors, the differences in color are super obvious to me.

The 8800K came from just observation/ trial & error while shooting. I've always done that with WB when it comes to shooting. But apparently, I'm going to have to change my method, since there doesn't seem to be a rhyme or reason behind the difference in color between the 2 and 3, and there doesn't seem to be a simple in-camera fix for it.

I think you are drawing conclusions from flawed data.  If it was mostly sunshine, then your light source temperature was changing from one shot to the next.  You should try the test again under more consistent light conditions.

Your WB setting seems to be mostly error, and the ExpoDisk is yielding flawed results.  As I noted above, you are sampling one light source [ light reflected from the wall ], and shooting with another light source [ direct sunlight ].  To top it off, your light source varies from one shot to the next, because of the variable cloud cover.  

You might be able to use the ExpoDisk as a grey card at these shooting distances.  You just won't be able to use the image as custom WB image.  You will have to sample the ED in post, and use it as a WB reference.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"I don't rent software. I use Photoshop CS6, ACR 9.8 and Lightroom 6.8 ."
Honored Contributor
Posts: 7,925
Registered: ‎12-07-2012

Re: Color Problem with 5D Mark 3

"Even with all those factors, the differences in color are super obvious to me"

 

You are making this far more difficult than it is. Just do as Tim and I have tried to guide you.  All will be well.  You do need to bone up on basic photography.  The grey card is a great idea.  No other fancy gadgets required.

A lot of Canon stuff. Along with, a lot of other stuff.
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement