Canon Community Canon Community

New Contributor
Posts: 2
Registered: ‎03-13-2018

Canon 70d screen goes fuzzy when I shoot a video

I was trying to shoot a video with my canon 70 D today and about 40 seconds in the screen went fuzzy and the video stopped recording, I tryied to turn the camera off but the screen remained fuzzy and frozen in place, I finally got the screen to turn off when I took out the battery. But when I tried to turn the camera on again, it wouldn’t come on. I tried changing the lens, taking out the batter and sd card and put it all back in and it worked to take pictures but not shoot video, I decided to give it a half hour break and replaced the address card, battery, and lens which made it seem like the camera was working again but sadly 40 seconds into the video, same problems again. Anyone out there ever experience this issue and know how I could maybe fix it?
Valued Contributor
Posts: 306
Registered: ‎11-19-2017

Re: Canon 70d screen goes fuzzy when I shoot a video

Perform a a battery pull.  Turn the camera off.  Re insert the battery and try again.  Given the high failure rates of the PCB / mainboard in 70Ds I suspect your has failed, or is failing like so many others.  I hope I'm wrong, but your description has all the sounds of what many here have described before as the end.

Bay Area - CA
~6D2 (f/w 1.0.3) ~16-35mm f2.8L II, 50 f1.8 STM, 85 prime, 70-200 f2.8L IS II ~Sigma 24-70 f2.8 Art
~Speedlite 430 EX II ~DPP 4.8.20 ~Windows10 Pro nVidia GPU 1709 ~Nexus6P Oreo 8.1 ~Samsung s9+ Oreo 8.0
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement