Canon Community Canon Community
 


Reply
Occasional Contributor
Posts: 22
Registered: ‎11-13-2012

Canon 5div Shutter release problem

Today as I went on a Mountain Hare shoot I got a complete surprise when my 5Div would not fire. Basically it achieves autofocus but then on full depress of the shutter button there is nothing. All of the items below made no difference.

 

1. Changed battery.

2. Left battery out for a few hours.

3. Changed lenses.

4. Removed and reinserted memory cards.

5. Complete reset using menu item. 

 

This would have been a complete disaster had our Hare guide not had a 1Dxii I could use. I did have my Sony A7Rii as a back up but AF is a bit hit and miss with Canon glass so I went with the 1Dxii as I previously owned a 1Dx mark i. Got some great images but still it was a tad stressful start to the shoot. 

 

Its still under warranty but any advice gratefully received. There doesnt seem to be a lot online about it this issue, not with the 5Div anyway. 

Esteemed Contributor
Posts: 4,183
Registered: ‎06-25-2014

Re: Canon 5div Shutter release problem

I notice that you didn't say that you tried live view. If live view works, it would at least rule out the possibility that the mirror is stuck in the down position,

Bob
Boston, Massachusetts USA
Highlighted
Occasional Contributor
Posts: 22
Registered: ‎11-13-2012

Re: Canon 5div Shutter release problem

Bob apologies, I forgot to add live view to the list. Live view is operational in terms of af etc but shutter still doesnt fire. 

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement