Canon Community Canon Community
 


Reply
Occasional Contributor
Posts: 5
Registered: ‎05-11-2018

80D Built In Flash Pops Up But Won't Fire

The built in flash on 80D pops up in Auto mode but won't fire.  I put "built in flash on" in the on mode and it will pop up but not fire.  I have been using 430EXIII RT and everything has been working fine.  Been shooting in P mode and built in flash and 430 have been working well.  Not sure if I have pressed the wrong button or what but I sure do need some help.  Thanks in advance.

Valued Contributor
Posts: 371
Registered: ‎11-19-2017

Re: 80D Built In Flash Pops Up But Won't Fire

Greetings,

Try reading this.  The entire thread...

 

http://community.usa.canon.com/t5/EOS/7D-pop-up-flash-not-firing-HELP/td-p/19721

 

Either Flash Fire Mode is turned off

Something in the hotshoe is keeping the flash from firing

or, the Camera needs to be serviced

 

Good luck.

 

Rick
Bay Area - CA
~6D2 (f/w 1.0.3) ~16-35mm f2.8L II, 50 f1.8 STM, 85 prime, 70-200 f2.8L IS II ~Sigma 24-70 f2.8 Art (f/w 2.0) ~Sigma 150-600 C (f/w 1.03)
~Speedlite 430 EX II ~DPP 4.8.20 ~Windows10 Pro nVidia GPU 1709 ~Nexus6P Oreo 8.1 ~Samsung s9+ Oreo 8.0
Occasional Contributor
Posts: 5
Registered: ‎05-11-2018

Re: 80D Built In Flash Pops Up But Won't Fire

Thanks for the link.  I attached my external flash (430EXIII-RT) to the hotshoe and it flashes.  Take the external flash off and the built in flash pops up like it wants to fire but does not fire.  I looked close on the hotshoe and did not see any small buttons stuck.  Any other advice???

Super Contributor
Posts: 197
Registered: ‎10-21-2016

Re: 80D Built In Flash Pops Up But Won't Fire

Even though the external flash fires the internal flash could be turned off in the menu, check the flash setup menu.
Occasional Contributor
Posts: 5
Registered: ‎05-11-2018

Re: 80D Built In Flash Pops Up But Won't Fire

[ Edited ]

Ok, I checked the flash control menu in the Program mode and the "flash firing" is in the "enable" mode, "E-TTL II", "shutter sync" is "1st Curtain".

In the Auto Mode I made sure the built in flash was in "on".  Still same deal.  Built in flash pops up but won't fire, but external flash on hotshoe will fire. Any other thoughts or suggestions.  Very much appreciated.

Valued Contributor
Posts: 481
Registered: ‎12-24-2013

Re: 80D Built In Flash Pops Up But Won't Fire

[ Edited ]

Your camera needs service. The flash is not working properly.

 

In the green Auto mode it is impossible to turn off the flash firing and there is no such menu option in the green Auto mode menu. Even with the flash turned off in the “Creative” modes like P, Av or Tv, the flash will still automatically pop up and fire in Auto mode. The  AF assist should also operate automatically and it also can not be turned off in full Auto mode.

 

The fact that the flash pops up automatically shows that there is no problem with the hot shoe sensor. The green Auto mode is commanding the flash to pop up and operate but the flash is defective. 

Mike Sowsun
S110, SL1, 80D, 5D Mk III
Highlighted
Occasional Contributor
Posts: 5
Registered: ‎05-11-2018

Re: 80D Built In Flash Pops Up But Won't Fire

Thanks for the information.  I went ahead and emailed Canon customer support.  Will update when they respond.

New Contributor
Posts: 1
Registered: ‎05-17-2018

Re: 80D Built In Flash Pops Up But Won't Fire

I am also having the same problem with my 80d
Occasional Contributor
Posts: 5
Registered: ‎05-11-2018

Re: 80D Built In Flash Pops Up But Won't Fire

Here was the response from customer service. It did not solve issue but was worth a try. Maybe it will help you.

Thank you for contacting Canon product support regarding your EOS 80D. I understand the built-in flash of your camera will pop-up, but not fire. I can assist you with this.

Based on the details of the issue it sounds like the flash bulb may be malfunctioning. I recommend performing a complete reset on the camera for further testing. Please follow the instructions below.

Settings Reset

1. While the camera is on turn the mode dial to "P" (Program mode), which allows all menu options to become available, then press the menu button.

2. Move across the top of the menu to the last wrench tab. (Yellow tabs)

3. Go down the menu list to "Clear Settings" and press the Set button.

4. Choose "Clear all Camera Settings", and press the Set button.

5. To complete the reset highlight "OK" and press the Set button again.

6. Next, move over to the Custom Functions menu list.

7. Reset the "Clear all Custom Func." settings as well.

Power Reset

1. Make sure the camera is off, and then remove the battery, memory card, and lens.

2. Close the battery/memory card doors.

3. Turn the power switch to the "ON" position, and then press and hold down the shutter button for 10 seconds.

4. Release the shutter button, turn the power switch to the "OFF" position, reinsert the battery, memory card, and attach the lens.

5. Power the camera on.

If the flash bulb still does not fire after the resets I recommend sending the camera body in for evaluation. Canon cameras come with a 1 year warranty from the date of purchase for manufacturer defects. As long as the camera has not been exposed to impact, pressure, liquid, or sand damage then it is eligible to be covered under warranty. The following instructions will outline how to send the camera in for warranty evaluation.
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement